Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem

I installed Ubuntu 12.04 on a Dell Inspiron 15R. As soon as I boot, the fan starts at full speed and stays constantly on. I've seen similar posts, where installing fan control apps are recommended like

i8kmon  
jupiter
mesa-utils

but in general, these do not allow for automatic fan speed control and one has to manually set the fan speed, while keeping track of the processor's temperature. See: Similar post.

Technical specs

  • Processor: Intel® Core™ i5-3337U CPU @ 1.80GHz × 4
  • RAM: 6 GB
  • Disk: 500 GB
  • Graphics: Standard Intel drivers
  • OS type: Ubuntu 12.04 (64-bit)

lm-sensors

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +45.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +40.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +45.0°C  (high = +87.0°C, crit = +105.0°C)

Any hint on how to solve this ?

share|improve this question
    
Do you have a dedicated video card besides that Intel thingy? –  OrangeTux Aug 6 '13 at 19:14
    
I just realized that without the dual monitor display, the problem does not appear ... If I start Ubuntu without plugging in the external monitor (Dell 23"), the fan does not start running at full speed. The problem may rely in the Intel drivers ?? –  Nicolas Aug 7 '13 at 15:30
    
@OrangeTux: No, the only Graphics card is the Intel one, so no external or Ubuntu drivers. –  Nicolas Aug 7 '13 at 15:31
    
@Nicolas what happens if you suspend? My Asus laptop sometimes does the same, and if I suspend and wakeup the fan stops. –  Salem Aug 8 '13 at 19:10
    
@Salem thanks for the suggestion, but as soon as I start it back, the fan starts running again. –  Nicolas Aug 8 '13 at 20:40

1 Answer 1

up vote 1 down vote accepted

I have the same notebook as yours, and the solution for me was 'i8kutils'. In this package the script 'i8kmon' is for automatic control.

Some tips are:

  • Put ENABLED=1 in /etc/default/i8kmon
  • Put set config(auto) 1 in /etc/i8kmon.conf

I hope it helps.

share|improve this answer
    
It seems to be working ! I'll keep an eye on the temperatures and let you know if anything changes. –  Nicolas Dec 10 '13 at 21:29
    
i8kmon did stop the fan noise, but somehow the automatic adjustment of fan speed does not work. Even if the temperatures are higher than the thresholds defined in /etc/i8kmon, the fan does not start. Any suggestions ? –  Nicolas Dec 16 '13 at 19:31
    
With the log we can have a better understand. To do that, just issue '$ sudo service i8kmon stop', and execute the script '/usr/bin/i8kmon' manually with the parameter '--verbose'. I think 20 seconds of log is sufficient. –  vitorafsr Dec 16 '13 at 21:27
    
Found the problem. I was not setting the temperature thresholds in the proper script. Thanks again ! –  Nicolas Dec 16 '13 at 23:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.