Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems enabling the Broadcom STA proprietary wireless driver.

I was using it previously, since I installed Ubuntu 10.10. I found out recently that this was causing problems with wired connectivity (a problem for another thread) so I switched to the Broadcom B43 wireless driver, which solved that problem. One problem that it raised is that wireless was often quite slow, especially if I had two thing simultaneously downloading. To verify this I testing download something in three areas of the city that I live in, each using a different ISP and the results were the same

So, I want to switch back to the Broadcom STA proprietary wireless driver, but when I activate it it doesn't work. It reads "This driver is activated but not in use".

What can I do to make it work? I've tried adding "wl" to /etc/modules and have followed advice from this thread but it hasn't worked of them have worked

I'm using Ubuntu 10.10. My computer specs: Dell Studio 1555: Pentium Dual Core T4300(2.1GHz,800MHz,1MB), 4096MB 800MHz DDR2 Dual Channel, 512 MB ATI Mobility RADEON HD 4570

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Have you tried to purge these things, reboot and go to proprietary drivers?

sudo aptitude purge i8kutils bcmwl-kernel-source bcmwl5700-source bcmwl-modealiases broadcom-sta-common broadcom-sta-source b43-fwcutte
share|improve this answer
    
Thanks, that worked! –  hellocatfood Apr 1 '11 at 10:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.