Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I start my Ubuntu computer and login, a GEdit window opens immediately; this window has nothing in it. I checked my startup applications and can't find the culprit.

I am not using the "automatically remember running application when logging out" option.

Here is my list of startup apps that are checked to run:

  • Certificate and Key Storage
  • Check for new hardware drivers
  • desktopnova-daemon
  • Disk Notifications
  • GNOME Login Sound
  • GSettings Data Conversion
  • Indicator for DesktopNova
  • Indicator-LockKeys
  • Lookit Screenshot Uploader
  • Network Manager
  • NVIDIA X Server Settings
  • Power Manager
  • Print Queue Applet
  • PulseAudio Sound System
  • PulseAudio Soudn System KDE Routing Policy
  • Remote Desktop
  • Secret Storage Service
  • Sound Icon
  • SSH Key Agent
  • Ubuntu One
  • Update Notifier
  • User folders update
  • Visual Assistance

I'm still very new to Linux and Ubuntu, so I'm sure there might be another place I can check that I'm not aware of.

Thank you to whoever can help me figure this out; and learn from it :)

share|improve this question
    
With this gedit window open - when you look at the list of running processes (via System Monitor or ps aux | grep gedit) - does the command in the list only say gedit or something more? –  arrange Mar 31 '11 at 22:01
1  
What is the output of ls ~/.config/gnome-session/saved-session/? –  Alvin Row Mar 31 '11 at 22:37
    
@DoR: output is: 103b560ff9ca70bf7e130121207975368700000013830042.desktop 105c004cfff969f961130117169168061200000041410028.desktop 105c004cfff969f961130117169168124200000041410029.desktop 105c004cfff969f961130117169168179200000041410030.desktop –  John 'Shuey' Schuepbach Apr 1 '11 at 22:11
    
@arrange: shuey 1823 0.5 0.8 173600 17140 ? Sl 17:09 0:00 gedit --sm-client-id 103b560ff9ca70bf7e130121207975368700000013830042 --sm-client-state-file /home/shuey/.config/session-state/gedit-1301212222.desktop shuey 2164 0.0 0.0 4012 748 pts/0 S+ 17:12 0:00 grep --color=auto gedit –  John 'Shuey' Schuepbach Apr 1 '11 at 22:13
add comment

1 Answer 1

up vote 5 down vote accepted

Disabling the Automatically remember running application when logging out option in Startup Applications doesn't cause gnome-session to forget the "remembered" applications. To do this, delete all the files in ~/.config/gnome-session/saved-session:

rm ~/.config/gnome-session/saved-session/*
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.