Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use my PC as a A2DP sink for my Nexus 7, but I can't seem to connect.

The bluetooth dongle I'm using is the ASUS-BT211

Error:Bluetooth

Things that I have tried already:

  • Adding Source to the pulseaudio "Enable" line.
  • Adding Socket to the pulseaudio "Disable" line.
  • Installing all bluetooth packages.

But still, it's not fixed.

Its not an adapter problem. It works fine in windows.

share|improve this question

closed as off-topic by Amith KK, BuZZ-dEE, New USer, LnxSlck, Avinash Raj Feb 21 '14 at 16:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Amith KK, BuZZ-dEE, New USer, LnxSlck, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you try if this still works? askubuntu.com/questions/2573/… –  Takkat Aug 6 '13 at 16:02
    
nope, it does not work :( –  Amith KK Aug 9 '13 at 6:22
    
Still reproducible? –  Braiam Feb 20 '14 at 3:20
    
I don't quite agree that this question should be closed as being very specific. This is a common problem with many bluetooth setups and headsets, and it seems the most common fix is that the pulseaudio bluetooth module isn't loaded. You can fix this by first running: pactl load-module module-bluetooth-discover –  David Ljung Madison Jan 24 at 14:14

1 Answer 1

I had a similar problem with my device. I own the bh-905i nokia headset and at first i wasn't even able to pair it, using my bluetooth dongle. This started happening after updating Ubuntu from 12.10 to 13.04 using livecd. My kernel is up-to-date. So: ->The device was detected by blueman, but couldn't pair by any means. ->After adding 'Enable = Socket' to the General section of /etc/bluetooth/audio.conf, i could pair it, but wasn't able to use a2dp stream. The error was "failed to change profile to a2dp". ->the headset appeared on the output tab, but it did not work at all (even though it was paired).

After struggling around a lot, i did this:

sudo alsa force-reload
sudo killall pulseaudio

restarted pulseaudio (alt+F2 pulseaudio)

then i added these lines in /etc/bluetooth/audio.conf

in [General] Disable=Socket

in [Headset] changed HFP value to HFP=false

and in [A2DP] SBCSources=1 and MPEG12Sources=0

then i restarted the bluetooth:

sudo restart bluetooth

and it WORKS now.

Unfortunately, if i disconnect the headset during the session i have to restart alsa and pulseaudio before trying to connect again.

Also, i change the profile to a2dp ONLY on blueman, because if i try to do that at the output tab of the sound manager (alsa, i think), i fail.

Bear with me, please, i am not an expert. And english isn't my first language. good luck!

share|improve this answer
4  
Nope, didn't work :( –  Amith KK Aug 17 '13 at 11:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.