Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu with a custom gnome-session which replaces the default window manager with xmonad. I.e., when I log in, I select "Xsession" in lightdm, and I have an .xsession file in my home directory which executes gnome-session --session=xmonad, where /usr/gnome-session/sessions/xmonad.session contains a modified gnome session which selects xmonad as the window manager. After upgrading to Ubuntu 13.04, the settings for specifying whether my desktop background/wallpaper should stretch or tile seems to have been removed! There is now just a single, large button for changing the wallpaper, but nothing else.

share|improve this question
    
If I recall correctly, you cannot change these options for the default Wallpapers, only. If you select your Pictures folder and select an image from there, the options are shown. No? –  hakermania Aug 6 '13 at 8:57
    
Nope, Pictures folder does not have these options either. This is a screenshot of what I get: snag.gy/j0vej.jpg –  Ulrik Rasmussen Aug 6 '13 at 9:30
    
Well, you don't seem to be using the defaults (something that you didn't mention on your question). This is what I get with the default settings program: i.imgur.com/yPSmVuZ.png –  hakermania Aug 6 '13 at 9:36
    
Ah, yes, of course! I actually run xmonad through gnome-session (using a custom gnome session file), so I thought that wouldn't make a difference. However, the system settings window is not the same when running a default session. I managed to fix it by adding the line "DesktopName=Unity" to my custom session file. Thanks for pointing me in the right direction :). Please make an answer if you want the credit ;) –  Ulrik Rasmussen Aug 6 '13 at 10:40
    
You found the answer yourself, actually. Edit your question to add the extra information about your desktop environment and make an answer yourself describing what you did to solve your problem. Next mark your answer as the one solving your question. –  hakermania Aug 6 '13 at 10:44
show 1 more comment

2 Answers

up vote 1 down vote accepted

The contents of the "system settings" window seems to depend on the name of the desktop environment, where the default GNOME desktop environment seems to have been dumbed down such that one cannot configure the tiling mode of the wallpaper. To get that functionality back, add the following line to /usr/share/gnome-session/sessions/xmonad.session:

DesktopName=Unity

For reference, the full session file then looks as follows:

[GNOME Session]
Name=Xmonad
RequiredComponents=gnome-settings-daemon;
RequiredProviders=windowmanager;panel;
DefaultProvider-windowmanager=xmonad
DefaultProvider-panel=lxpanel
DefaultProvider-filemanager=/bin/true
DesktopName=Unity
share|improve this answer
add comment

The option you are looking for is in System Settings>Appearance

Next select the option circled below.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.