Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed PHP5.4 from PPA ppa:ondrej/php5-oldstable in my Ubuntu 12.04.2.

Then all of my image processing scripts got broken. Turns out the php5-gd library isn't loaded.

$ php -a
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/gd.so' - /usr/lib/php5/20100525/gd.so: undefined symbol: gdGetC in Unknown on line 0
Interactive mode enabled

Here's some package installed in my machine related to GD (hope might help, let me know if you need to know details of other packages):

ii  libgd2-xpm                                    2.0.36~rc1~dfsg-6ubuntu2                GD Graphics Library version 2
ii  libgd2-xpm:i386                               2.0.36~rc1~dfsg-6ubuntu2                GD Graphics Library version 2
ii  libgd3                                        2.1.0-2~precise+1                       GD Graphics Library
ii  php5-gd                                       5.4.17-4+debphp.org~precise+1           GD module for php5

Is there any way to fix this?

share|improve this question
    
I will look at this problem. It's not a real question though – it's a bugreport and I just cannot sieve through all askubuntu.com questions, so I would point you to debphp.org, where you will find a debphp-user (and debphp-announce) mailing list just suited for the purpose. –  oerdnj Aug 6 '13 at 10:43

2 Answers 2

up vote 1 down vote accepted

The real culprit is the fact that PHP 5.4 GD extension is not compatible with libgd (>= 2.1.0). Since the gd.so is an dynamic extension it's not possible to detect the missing symbols at compile time.

Anyway the php5-oldstable has been updated:

  • libgd 2.1.x has been removed
  • new php5 has been updated with forced dependency on libgd 2.0.x

E.g. this bug has been fixed in php5 5.4.17-5+debphp.org~+1 (some dists are still building at the time of writing this answer).

share|improve this answer
    
thanks a lot for the quick response. it works now. should there be another bug, i will report it right away in the link you gave above. thanks! –  Petra Barus Aug 6 '13 at 12:09

sudo apt-get install php5-gd worked for me after I had to switch from stable to old-stable due to an older apache.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.