Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My computer was just able to connect a minute ago but after I restarted it can find WiFi signals and knows the password but won't connect. It's within range of the WiFi signal, but simply refuses to connect. Let me know of any additional info you might need. Thanks for any help.

My WiFi just connected right after I entered these commands. Can you tell whether or not my connectivity will still be unstable?

lspci | grep network gives me no output

iwconfig" yeilds
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

eth0      no wireless extensions.



nm-tool" yeilds
NetworkManager Tool

State: disconnected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             disconnected
  Default:           no
  HW Address:        78:DD:08:DF:9A:76

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    Azcasa1:         Infra, C8:D7:19:E3:B1:DA, Freq 2462 MHz, Rate 54 Mb/s, Strength 35 WPA WPA2
    airplane:        Infra, 00:16:B6:0D:A1:1A, Freq 2437 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
    Ranger:          Infra, C4:3D:C7:56:BA:A8, Freq 2462 MHz, Rate 54 Mb/s, Strength 30 WPA
    guest:           Infra, 1C:E6:C7:0C:DF:C0, Freq 2412 MHz, Rate 54 Mb/s, Strength 25
    MOTOROLA-3F559:  Infra, 20:10:7A:DC:E5:3E, Freq 2462 MHz, Rate 54 Mb/s, Strength 19 WPA2
    Exiga:           Infra, 10:9F:A9:AC:3F:44, Freq 2412 MHz, Rate 54 Mb/s, Strength 54 WPA WPA2
    myqwest0382:     Infra, 62:39:44:58:13:31, Freq 2437 MHz, Rate 54 Mb/s, Strength 24 WPA WPA2
    myqwest0381:     Infra, A8:39:44:58:13:34, Freq 2437 MHz, Rate 54 Mb/s, Strength 20 WEP


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        54:42:49:2A:B4:E7

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off
share|improve this question
    
Please, edit your post and add the following output: lspci | grep network, iwconfig and nm-tool. –  Braiam Aug 6 '13 at 2:14

1 Answer 1

Run the commands one line at a time, just copy and paste for accuracy, it usually gets this driver to connect better. You only have one network with a strong enough signal to connect too, and it is barely strong enough, it is myqwest0382 so I hope that is the network you are trying to connect too.

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

sudo modprobe -rfv ath9k

sudo modprobe -v ath9k

Thanks

share|improve this answer
    
The signal I'm trying to connect to is "exiga"which shows a higher strength than the one you said, if the higher the strength value shown is the stronger the strength of the signal. It just doesn't make sense why the signal would start to get screwy on me now. –  Paul Ronquillo Aug 6 '13 at 7:45
    
I see that now that code blocks have been added. Did the commands help? If not were there any errors? Also it is usually best to have the routers encryption set to just wpa/2 if you have that option. –  Wild Man Aug 6 '13 at 14:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.