Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to use the Radeon 8790M on my Dell Latitude E6540 running Kubuntu 13.04 (Raring). This laptop also has an Intel adapter (for power saving). lspci gives:

$ lspci | grep VGA 
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Mars [Radeon HD 8790M]

Tried using the standard fglrx and fglrx-update and aticonfig results in (in a message box):

aticonfig: No supported adapters detected

Trying AMD's drivers always renders the same result:

Your graphics adaper is not supported by this driver. Installation will not proceed. 

There is no 3D acceleration, as evident by running glxgears:

$ glxgears 
X Error of failed request:  BadRequest (invalid request code or no such operation)
Major opcode of failed request:  153 (GLX)
Minor opcode of failed request:  19 (X_GLXQueryServerString)
Serial number of failed request:  12
Current serial number in output stream:  12

This may be an issue of the multi-adapter situation, but I'm not sure how to resolve this.

share|improve this question
    
Thanks for asking this Stanga, if this isn't resolved, do you know if the radeon can be disabled fully in linux and have any external displays still work? Also, how is the power usage in powertop with the radeon off? –  Mike Aug 6 '13 at 20:05
    
Doesn't look good. As far as i understand the Radeon isn't active, though probably not fully disabled. I found no way to effect this situation. I'm not even sure whether the latest driver (3.8) does not recognize the adapter because the driver is broken (it is beta) or because the Radeon is switched away in favor of the Intel. Anyway, external screen works fine, and power consumption is as expected. –  stanga Aug 13 '13 at 23:44
add comment

2 Answers 2

up vote 1 down vote accepted

Indeed patience was the solution.

ATI just published an updated driver (13.8 beta2), which installs successfully.

share|improve this answer
add comment

I suppose you have installed AMD Catalyst™ 13.4 Proprietary Linux Graphics Driver. Read the Release Notes for Catalyst™ 13.4. It does not support the AMD Radeon 8000 series. May be you should try installing AMD Catalyst™ 13.8 LINUX Beta Driver. It supports 8000 series according to the link. Warning: 13.8 is still in beta stage.

share|improve this answer
    
Thanks yash. Tried 13.4, the beta and an older version. All resulted in the same Your graphics adaper is not supported by this driver. Installation will not proceed. –  stanga Aug 6 '13 at 18:06
    
May be you should wait for the Official 13.8 release. Its a bummer, I know. Similar thing happened to me way back when HD5000 series was new and AMD's website still hadn't released supporting drivers. If you haven't tried Section 2.1. Installing via command line from here, give it a shot. It will install the most appropriate drivers. Don't forget sudo apt-get update before you start installing via command line. –  Yash Aug 7 '13 at 14:24
    
This user has similar problems. You might want to go through for some suggestions. –  Yash Aug 7 '13 at 14:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.