Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a netbook with an AZERTY layout. I've changed it to "bépo" to try it, but now I've reset it to a french layout.

While all the apps have taken the change into account, Ubuntu's login manager still uses bépo, making entering passwords a challenge. I've enabled the virtual keyboard for the time being so that I could login again.

I don't remember what I had done in the first place to switch the login screen to bépo, but now I can't switch it back.

enter image description here

EDIT : In the keyboard settings page, if I click "use system defaults", then everything is in bépo ! Where is this different keyboard layout set ?

ANOTHER EDIT : Here's what did not work :

  1. Changing the layout in settings
  2. using the "use system defaults" checkbox in settings
  3. sudo dpkg-reconfigure keyboard-configuration
  4. changing it in Xconf
  5. adding a line in /etc/lightdm/lightdm.conf
  6. sudo dpkg-reconfigure locales
  7. slaming head against desk
  8. dpkg-reconfigure lightdm
  9. sudo gsettings set org.gnome.libgnomekbd.keyboard layouts "['fr']"
  10. combinations of the above

enter image description here

Is it possible to relaunch the keyboard configuration tool that's in ubuntu's setup ? The thing has automatic layout detection and it changes the setting everywhere.

share|improve this question
    
maybe try to switch your keyboard with this command : sudo dpkg-reconfigure keyboard-configuration , or did i missunderstand something ? –  Private Aug 5 '13 at 15:07
    
I had tried sudo dpkg-reconfigure lightdm, will try yours now –  Manu Aug 5 '13 at 15:14
    
Nope, it's still the same keyboard at the login screen. –  Manu Aug 5 '13 at 15:17
    
If one of the answers solved your problem, please accept it. (even if it's your own) –  minerz029 Feb 17 at 10:32

4 Answers 4

Make a short-key in System Settings > Keyboard Layout > Options under "key(s) to change layout" to switch layouts.

You can see detailed answer here Keyboard shortcut for Lockscreen not working

share|improve this answer
    
The layout change key doesn't seem to have any effect on the login screen. –  poolie May 20 at 4:12

From terminal, run the following command to set the language layouts (you can set maximum four layouts) for your lightdm login screen:

gsettings set org.gnome.libgnomekbd.keyboard layouts "['us\taltgr-intl', 'fr']"

With the above command you set English (International) and French layouts, but you can change them as you wish.

To see the current layouts, you can use:

gsettings get org.gnome.libgnomekbd.keyboard layouts

Now, you should be able to use the keyboard icon from the top-right of your screen:

keyboard icon

Next is a screen capture from my login screen (I used gsettings set org.gnome.libgnomekbd.keyboard layouts "['us\taltgr-intl', 'gr', 'ro']" in terminal). As you can see, I can change the language layout as I wish:

login screen

share|improve this answer
    
I thought of that of course, only "french/bépo" appears in that list. –  Manu Aug 21 '13 at 19:36
    
@Manu Why don't you add another one keyboard layout? –  Radu Rădeanu Aug 21 '13 at 19:39
1  
I keep doing that, the layout at the login screen are not the same as the layouts once logged in –  Manu Aug 21 '13 at 19:46
    
@Manu Then use this command from terminal to set layouts (you can set maximum four layouts): gsettings set org.gnome.libgnomekbd.keyboard layouts "['us\taltgr-intl', 'fr']" (for English - International and French). To see the current layouts, use: gsettings get org.gnome.libgnomekbd.keyboard layouts –  Radu Rădeanu Aug 21 '13 at 19:56
    
I tried "['fr']" but that did not work. Problem is the layout is already in French, but in the wrong variant. –  Manu Aug 21 '13 at 20:10

Must have been a weird lightdm bug.

Lightdm got the new keyboard layout once I changed the login manager to gdm, then back to lightdm, even though simply doing dpkg-reconfigure lightdm did nothing.

So here it is :

sudo apt-get update
sudo apt-get install gdm

(set gdm as the login manager when asked)

sudo dpkg-reconfigure lightdm

(set it as the login manager when asked)

sudo apt-get remove gdm

Then, restart.

Changing a keyboard layout in linux is serious business.

share|improve this answer

What did seem to work for me was this suggestion: change /etc/default/keyboard.

Banging head on desk indeed, this is ridiculous.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.