Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have very big problem with mobile broadband connections... I tried on my laptop to connect and searched the web for possible solution, but didn't found it.

The problem is that i DON'T have the menu Mobile Broadband. I have only Wireless and Wired connection. I even don't see the Enable Mobile Broadband! I had success with one USB modem with sakis3g, but on my new Alcate didn't worked.

I've tried also on new freshly installed Ubuntu 12.04 on PC, and again - no menu at all for Mobile Broadband! When I open "Network connections" I have menu Mobile Broadbands and when I add a connection - nothing happens, it shows me "last used - never"

In addition to add - In "Networks" I can't add Mobile Broadband, I only have Wired, Wireless, Network Proxy and when I try to add ne type it only shows VPN option.

When I saw I didn't have "Mobile Broadband" in network manager I tried to reinstall it and did big mess, now my menu is very strange (I thing I didn't installed the amd64 at first and that's why it's so weird )

share|improve this question

Following packages are needed for the network-manager to work properly. If one of them is not problems arise. Specially it needs modemmanager to work with Mobile Broadband. Try with installing all. Terminal will install the deficient.

sudo apt-get install dpkg multiarch-support dbus dnsmasq-base iproute iputils-arping isc-dhcp-client libc6 libdbus-1-3 libdbus-glib-1-2 libglib2.0-0 libgudev-1.0-0 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnm-glib4 libnm-util2 libpolkit-gobject-1-0 libsoup2.4-1 lsb-base policykit-1 udev upstart-job wpasupplicant crda iptables modemmanager network-manager-gnome network-manager-pptp ppp avahi-autoipd
share|improve this answer
up vote 1 down vote accepted

The USB Modem was recognised as Flash Memory and that was the problem! The only thing you have to do is this:

Disk Utility -> The USB FLASH drive(there will be 2 devices for you Model, choose the CD/DVD drive) and UnMount it!

That's it! After this wait a little bit and you're ready!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.