Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have successfully connected my Canon MG6150 to my laptop, using the "Add Printer" function. However, the print command only works over a USB connection. The laptop connects wirelessly to my BT HomeHub 3 and the internet but when I check the network, none of the other devices on the network are shown. Likewise, when I check the network on my windows-based desktop, it shows everything but this laptop. I'm using Ubuntu 12.04.

Any help will be much appreciated

share|improve this question

When you added the printer, was it connected by USB at the time?

You may need to force it to find it wirelessly by unplugging the printer and then doing "Add -> Network Printer -> Find Network Printer". This worked for me with a Canon MG6250.

share|improve this answer
Find gives me the result No printer was found at that address. Apparently I must enter a host but what could that be? Screenshot and my related question. – Torben Gundtofte-Bruun Sep 16 '13 at 19:55

You should be able to use Find Network Printer and use the printer ip address in order to identify the proper printer. I have the same printer that method worked for me.

share|improve this answer
@Tim This looks like an answer to me.. – Seth Jun 25 '15 at 23:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.