Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to compile lsyncd from the sources, it gives this error: make[1]: *** [luac.out] Error 1 even though I had done apt-get install liblua5.1-0-dev liblua50-dev liblualib50-dev.

The lsyncd avaialble in apt-sources is 1.35, which doesn't have ssh support. How can I get lsyncd 2 working on ubuntu 10.10?

share|improve this question
    
Can you do a pastebin link of the whole compile output? –  Code Friendly Mar 31 '11 at 17:32

1 Answer 1

up vote 2 down vote accepted

I was able to have it compile successfully by just installing the following (same version of Ubuntu):

sudo apt-get install lua5.1 liblua5.1-0-dev

Then

./configure && make

This is in an environment where all the normal build/compile tools are already installed, so if you were to link a pastebin of your compile process, maybe we can see if something else is missing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.