Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do i set up my server so it is visible from the outside?

I have set up port forwarding (port 80) to my server. I have also set up a static ip for the server.

I think the cause is the server (Apache2 on Ubuntu Server 13.04) says that it can't reliably determine the FQDN.

Here is the result of hoastname: Elliot-Web Here is the result of hostname -f: hostname: Name or service not known

Here is the hosts file contents:

127.0.0.1       localhost
127.0.1.1       Elliot-Web.elliot-labs.com

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

And if you are wondering I have set up my domain to point to my WAN ip (from godaddy).

share|improve this question
    
it doesn't work for me. heres my address: www.elliot-labs.com –  Elliot Labs Aug 4 '13 at 15:52
    
i have my server on and i can see it from my intenal ip (192.168.0.25)(static) but not my web address. –  Elliot Labs Aug 4 '13 at 15:53
    
a while back. I can ping my web address and I get a response from my WAN. So it is pointed to my WAN address. –  Elliot Labs Aug 4 '13 at 15:56
    
No and that is the proub. I personally think that the proub is somewhere in apache2 not finding the FQDN. –  Elliot Labs Aug 4 '13 at 16:01

2 Answers 2

The problem isn't for the most time a local IP, it's a global IP. The global IP must be specified in your DNS host so that your domain name is linked to the global IP of your host. IF this link is broken the router wont get any data and the site will be unavailable.

Things to check.

  • Is the website accesable via the global IP?
  • is the global ip the same as the IP of the domain name?
  • is the router configured to send all website request to your server?
  • does the server work on the local IP?

apache doesn't need a domain name it just needs a working link to the real world, like a global IP, then link your domain name to that global IP.

share|improve this answer
    
yes to all except the first one. It works on MS IIS 7 (MS Server 2008) but not on LAMP Apache2 (Ubuntu Server 13.04). –  Elliot Labs Aug 4 '13 at 16:07
    
@ElliotLabs then it's a problem with your router not sending the packets to your server. –  Alvar Aug 4 '13 at 16:08
    
here is my server config info (port forwarding): 'Port 80 fwarded to 192.168.0.25'.Which is my server's internal IP –  Elliot Labs Aug 4 '13 at 16:12
    
I have DD-WRTv24SP2 (03/19/12) on a netgear WNR 2000v3 –  Elliot Labs Aug 4 '13 at 16:14
    
I am going to reset my router to default settings and then i am going to port forward port 80 to my server. –  Elliot Labs Aug 4 '13 at 17:32
up vote 0 down vote accepted

I reset it but no luck. Then I tried accessing it from my neighbors Wi-Fi... It worked YARGHHHH! So it must be a problem with my local network. Dug around for DNSMasq settings and figured out how to redirect elliot-labs.com to my server so instead of my WANN ip it is my Local IP that is in the background. It worked like a charm plus another side effect of this is no lag on my network (No idea why...). Thanks for all of your help Alvar. I didn't have any proub from accessing from my WAN it was LAN.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.