Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have HDD for Ubuntu 13.04 with this structure:

(Ext4) - /dev/sdb2 mounted at "Filesystem Root" a.k.a "/"

(Ext4) - /dev/sdb6 as "/home" (can't mount it)

(Swap v2) - /dev/sdb5 as "Linux swap"

The owner of "/dev/sdb2" ("/") is "root".

The owner of "/dev/sdb6" (/home drive) is me. I wanted to create folders with my files outside the "home" folder in this drive and so I took the rights.

Now if I try to boot Ubuntu, at start I got something like "Ubuntu cannot mount drive /home. Press "S" to skip or "M" for manual recovery."

Manual recovery leads me to root terminal, but I don't know exactly how to fix this."#mount /dev/sdb6" or "#mount /home" don't work.

If I press skip, it leads me to user login panel. And there is the funny part. I can't login my user account. I know my password, but it just does not work. I even tried to change the password from the root terminal (recovery console) with "passwd" successfully and still don't work.

So atm I can login only as Guest. And here I have very limited rights. I can use the root recovery console mentioned above, but its up to you to tell me what commands to use there.

If i try to mount "/home" (/dev/sdb6) from the Guest account, using the "Disks" utility, first asks me for the password to my account and then I get this:

  Error mounting system-managed device /dev/sdb6: Command-line `mount "/home"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdb6,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

 (udisks-error-quark, 0)

Thanks for the help.

Edit

If I try to use the root recovery console and type "#mount /home" I get this: enter image description here

Feedback:

For "namingFailed"

The official owner was "root". When I installed Ubuntu 13.04, I set the "/dev/sdb2" as "/" and "/dev/sdb6" as "/home". I had some hesitation about the size of every partition and that's why I have missing numbers like "sbd1, sbd3 and sbd4". Anyway those partitions are complitly gone. Ubuntu 13.04 was installed only with 3 drives (sdb2, sdb5 and sdb6) as "fstab" shows..

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc2 during installation
# /home was on /dev/sdc6 during installation
# swap was on /dev/sdc5 during installation
UUID=29d5e133-70ed-43ed-a61f-cfcf9adaa510 none            swap    sw              0       0
/dev/disk/by-uuid/36125EFB125EBF93 /mnt/36125EFB125EBF93 auto nosuid,nodev,nofail,noauto 0 0
/dev/disk/by-uuid/01CC4CEEBE6F62C0 /mnt/01CC4CEEBE6F62C0 auto nosuid,nodev,nofail,noauto 0 0
/dev/disk/by-uuid/01CC4CC16B0EE880 /mnt/01CC4CC16B0EE880 auto nosuid,nodev,nofail,noauto 0 0
UUID=cfc08790-4674-4eec-ab23-a112e8f97478 /home ext4 defaults,x-gvfs-show 0 2
UUID=096b6f57-28af-4f20-aec8-8a5411814614 / ext4 errors=remount-ro 0 1
/dev/disk/by-uuid/01CC4CEEE36CFD80 /mnt/01CC4CEEE36CFD80 auto nosuid,nodev,nofail,x-gvfs-show 0 0

For "mikewhatever"

#sudo chown -R fearbg:fearbg /home
#sudo chmod -R 755 /home

After that I was able to make new folders outside the "fearbg" home folder.

share|improve this question
    
Have you always been the owner of the /home partition ? also can you post your /etc/fstab as this tells the computer how to mount the partitions. –  namingFailed Aug 4 '13 at 15:17
    
"I wanted to create folders with my files outside the "home" folder in this drive and so I took the rights." Took the rights of what? What exactly did you do? –  mikewhatever Aug 4 '13 at 15:20

2 Answers 2

up vote 2 down vote accepted

It may be bug. Check https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/1011257

Try removing ,x-gvfs-show from /etc/fstab

share|improve this answer
    
You are the man! I did "#nano /etc/fstab" in the recovery terminal and after removing the "x-gvfs-show" value I get my account back, I can access "/home" and everything is back to normal. Much obliged! –  FEarBG Aug 4 '13 at 17:24

Try moving that folder from outside /home directory to inside it, and running again, changing the permissions to default. ? I guess that can solve your query. Also, "The owner of "/dev/sdb6" (/home drive) is me. I wanted to create folders with my files outside the "home" folder in this drive and so I took the rights." ? When you have the rights already to "/dev/sdb6" drive then why would you want that again ?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.