Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu on my dell inspiron 14z, currently only in my HDD. Before installing that, I switched to AHCI, turned off Intel rapid storage technology, turned off secure boot. Then while making the new partition table I choose GPT, and installed ubuntu.

But when I restarted the system, it was showing an error message as "No operating system found". In boot options ubuntu was showing beneath the "UEFI" tab.

Even after running boot-repair, it prompted that my OS is installed in EFI mode. But I am unable to understand how is that possible, when I installed it in legacy mode.

EDIT: boot repair url is http://paste.ubuntu.com/5954568/

share|improve this question
    
Please indicate the URL provided by the Boot-Repair utility. –  LovinBuntu Aug 4 '13 at 17:54
    
You didn't install in BIOS/CSM/legacy mode. Enabling "legacy mode" in your firmware just makes it possible to install in BIOS/CSM/legacy mode. EFI mode is almost certain to still be supported, and depending on how you booted the installer, it might have installed in EFI mode. Running Boot Repair might fix the problem, and if not, the URL to its output will give us more to work on to get the system working. –  Rod Smith Aug 4 '13 at 22:46
    
I have added the boot-repair url, above. –  rishy Aug 6 '13 at 10:21
add comment

2 Answers

The Legacy mode can not boot a GPT drive, there are exceptions for different hardware I think, but you must use UEFI in order to boot the GPT drive. So, after formatting your drive to GPT the installer assumes you have booted in UEFI mode and installs the OS for the UEFI mode.

Since, you had boot problems with the Legacy mode and the GPT drive I think you can not boot a GPT drive using the Legacy mode, no matter what the operating system. That's what I would recommend you to do:
- Enable the UEFI mode
- If you were able to boot into the Ubuntu it is great, but if it did not boot use your live Ubuntu and use boot repair to repair booting in UEFI mode.

share|improve this answer
1  
It's possible to boot a GPT disk in BIOS/CSM/legacy mode. The exceptions are with buggy BIOSes (or EFIs), some of which throw extra hurdles in the path of attempts to boot in this way. See this page for details. In any event, a BIOS/CSM/legacy-mode install to a GPT disk is not the source of rishy's problems, judging by the Boot Info Script output. –  Rod Smith Aug 7 '13 at 18:37
add comment

It's not 100% clear what your current problem is; however:

  • Your Windows is definitely installed in BIOS mode to /dev/sda, which is an MBR disk.
  • Your Ubuntu appears to have been installed in EFI mode to /dev/sdb, which is a GPT disk. (Your /home is on /dev/sda2, though.)

This configuration is awkward because switching boot modes typically requires mucking about with firmware settings on each reboot. (See below for one possible way to simplify this, though.) It's unclear to me which of these OSes you're able to boot. Your initial post suggests that nothing boots, but the Boot Repair output seems to indicate that you've successfully booted Linux in EFI mode:

efibootmgr -v
BootCurrent: 0011
Timeout: 0 seconds
BootOrder: 0000,0001,0002,0003,0011
Boot0000* P0: WDC WD5000LPVT-75G33T0        BIOS(10,0,00)AMBO
Boot0001* P4: TSSTcorp DVD+/-RW SU-208BB    BIOS(12,0,00)AMBO
Boot0002* Atheros Boot Agent    BIOS(14,0,00)AMBO
Boot0003* P1: SAMSUNG SSD PM830 mSATA 32    BIOS(15,0,00)AMBO
Boot0011* ubuntu    HD(1,22,2faf1,9cbd791f-e51b-4808-8506-314beba6aee9)File(EFIUbuntugrubx64.efi)

The BootCurrent: 0011 line suggests that you've booted Ubuntu via its EFI boot entry, Boot0011. OTOH, that entry appears to be malformed (EFIUbuntugrubx64.efi rather than \EFI\ubuntu\grubx64.efi), so your current state is puzzling to me.

In any event, I can think of a number of options for how to proceed:

  • Run Boot Repair and tell it to do a BIOS-mode GRUB repair. I'm not sure precisely what options you'd select to do this, though.
  • Re-install Ubuntu in BIOS/CSM/legacy mode. You'll need to force this boot mode by fiddling with firmware options or by using your firmware boot manager's options to select a BIOS-mode boot rather than an EFI-mode boot. Once you boot the installer, drop to a shell and look for a directory called /sys/firmware/efi. If it's present, you've booted in EFI mode and should try again; if it's present, you've probably booted in BIOS mode. Note that it is possible to install to a GPT disk in BIOS mode, although some BIOSes have bugs that may require jumping through some hoops.
  • In an EFI-mode Linux boot, install my rEFInd boot manager. Once it's installed, edit /boot/efi/EFI/refind/refind.conf: Locate the scanfor item, uncomment it, and ensure that hdbios is among the boot options. With any luck, when you reboot, you'll see a gray icon that will boot Windows in BIOS mode, along with options to boot Linux in EFI mode. Unfortunately, rEFInd's BIOS-boot support doesn't work on all systems, so I can't promise this will work for you. If it does, though, it may be the easiest way to get your existing setup working.
  • Re-install Windows in EFI mode. This will require converting /dev/sda from MBR to GPT (which gdisk can do), and you'll also need to force the Windows installer to boot in EFI mode (which can be tricky, and I don't have specific pointers, offhand).
  • Convert Windows to boot in EFI mode, as described here. This is a tricky and risky procedure, but it stands a good chance of working.

One more tip: If you keep GPT on /dev/sdb, you should use gdisk to convert /dev/sdb2 from what gdisk calls type 0700 to 8300. This will keep the Linux root partition from showing up as an "unformatted disk" in Windows. See this page for more on this issue.

share|improve this answer
    
Have just recently installed gdisk. Ubuntu Software Centre could find gdisk but would not authorise the installation of "sudo apt-get install gdisk" was far more obliging. Found gdisk to be very easy to use and the author provides very informative manual and help built in (man gdisk)as well as his web pages being uncomparabily superiorly informative which are also very meaty and well maintained/updated. Highly recommended. –  geezanansa Aug 10 '13 at 1:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.