Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Asus laptop with Atheros AR9285 Wireless Network Adapter. I've installed Ubuntu 13.04. I tried sudo rfkill block all and the output of rfkill list all is

0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: asus-wlan: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

Is there any way to put hard block on both WiFi and Bluetooth?

Any help would be appreciated.

share|improve this question
    
Just to be clear you want to block wifi and bluetooth so they do not work? –  Wild Man Aug 4 '13 at 15:58
    
I want to do that for the sake of power consumption. But in a way that whenever I need WiFi and Bluetooth, I could remove them from block list. –  Babak Aug 4 '13 at 16:12
1  
Hard blocks are done by the physical switch on your computer being turned off, if it is not a switch on your system then it is controlled by a key combination for example FN key + f5. We might could write a script but then you would have to enter commands to turn wifi and bluetooth on. Wifi has power management built in automatically to save power when running on battery unless you have deactivated it. You can check with iwconfig –  Wild Man Aug 4 '13 at 16:26
    
Thank you for help. –  Babak Aug 4 '13 at 16:39
    
Did that give you the results you want? –  Wild Man Aug 4 '13 at 16:43

1 Answer 1

up vote 0 down vote accepted

Hard blocks are done by the physical switch on your computer being turned off, if it is not a switch on your system then it is controlled by a key combination for example FN key + f5. We might could write a script but then you would have to enter commands to turn wifi and bluetooth on. Wifi has power management built in automatically to save power when running on battery unless you have deactivated it. You can check with iwconfig

share|improve this answer
    
I understand your comment. That is clear. But I'm not able to turn Bluetooth on. I've tried different commands But No one work! There is only one way! I must restart my laptop after switching on by Fn + F2. –  Babak Aug 4 '13 at 17:25
    
You can try sudo modprobe ath9k btcoex_enable=1 –  Wild Man Aug 4 '13 at 17:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.