Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

2 days ego i updated my Ubuntu 12.04 LTS to latest updates but i ignored Grub Updating because I thought it will clear my grub settings (I'm so noob!). After restart every things was right, the Ubuntu started normally and every things was working well except graphic which had problem before update.

I had the experimental driver before but I changed it to the current-update version. After restart Ubuntu stock on black screen. I tried to reinstall Nvidia driver from recovery but it not worked.

Then i used Update Grub in recovery, it not worked too but i see this line on screen at boot:

enter image description here

at this time it stops and keyboard not working, but when I push the power button it shows these lines and it will shutdown.

enter image description here

OK finally I made it start with older kernel (3.5.0-28-generic). Now how can I keep this kernel or fix Ubuntu to work with new kernel? Should I reinstall Nvidia driver? Which version should I use?

share|improve this question

3 Answers 3

up vote 8 down vote accepted

i have same issue.

In /var/log/syslog i have found next lines:

[   13.834336] NVRM: API mismatch: the client has the version 319.32, but
[   13.834336] NVRM: this kernel module has the version 304.88.  Please
[   13.834336] NVRM: make sure that this kernel module and all NVIDIA driver
[   13.834336] NVRM: components have the same version.

It`s mean, that 2 kerenl modules installed.

In dkms i have seen 2 modules installed.

dkms status
nvidia-304-updates, 304.88, 3.5.0-39-generic, x86_64: installed
nvidia-319-updates, 319.32, 3.5.0-39-generic, x86_64: installed

Just delete previous module, and it work`s for me.

sudo apt-get purge nvidia-304 nvidia-304-updates
share|improve this answer
    
Thanks, it worked well. –  nDman Aug 20 '13 at 12:05
    
Yes! Thanks for this one. Seems like a bug in 12.04 LTS: On my fresh installation the 304 driver was selected and activated in the restricted driver panel. Changing to 319 and restarting caused the issue described in the question. –  Christoph Halang Oct 21 '13 at 20:30

after some tests I found that packages:

nvidia-current
nvidia-304
nvidia-settings
nvidia-settings-304

work for all kernels 3.2.0-* and 3.8.0-*,

while packages:

nvidia-current-updates
nvidia-experimental-304
nvidia-304-updates
nvidia-settings-updates
nvidia-settings-experimental-304
nvidia-settings-304-updates
nvidia-319
nvidia-experimental-310
nvidia-319-updates
nvidia-settings-319
nvidia-settings-experimental-310
nvidia-settings-319-updates

work for Kernel 3.8.0-* only.

Ubuntu jockey still Recommend 319 version also when kernel 3.2.0-* only are present. So a bug here.

Furthermore the commands:

$ sudo apt-get purge nvidia-current
$ sudo apt-get install nvidia-current

or

$ sudo dpkg-reconfigure nvidia-current

install the driver for only one version of kernel for each minor version, and remove it for all the others.

So, in my case that I have the following kernels installed:

3.8.0-32-generic
3.2.0-55-generic-pae
3.2.0-55-generic
3.2.0-54-generic-pae
3.2.0-54-generic
3.2.0-53-generic-pae
3.2.0-53-generic
3.2.0-52-generic-pae
3.2.0-52-generic
3.2.0-51-generic-pae
3.2.0-51-generic
3.2.0-49-generic-pae
3.2.0-49-generic

I got the driver only for:

3.8.0-32-generic
3.2.0-55-generic-pae

while booting with the other kernels, the driver results not installed.

Seems to me that somewhere in the package there is a wrong indication to build and install for some kernel only.

Anywhere, issuing the following command fix the situation:

$ sudo dkms install nvidia-304/304.88 -k 3.8.0-32-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-55-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-55-generic-pae
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-54-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-54-generic-pae
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-53-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-53-generic-pae
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-52-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-52-generic-pae
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-51-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-51-generic-pae
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-49-generic
$ sudo dkms install nvidia-304/304.88 -k 3.2.0-49-generic-pae

until the next apt-get install nvidia-current or reconfigure

Thread: Nvidia driver updated - mixed versions of 304.88 and 319.32 is related to the same, but I had no enough credit to post there.

share|improve this answer

I used the following to grep the syslog:

cat /var/log/syslog | grep -C5 "NVIDIA"

To get the currently installed modules:

dkms status

To remove NVIDIA problem driver found in the syslogs

apt-get purge nvidia-304*

Almost forgot to make sure grub updates...

update-grub

Then reboot and you should be golden (fingers crossed)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.