Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After i installed TeamViewer 8 on Ubuntu 12.10, i noticed a running process under the name of 'teamviewerd', more specifically:

/opt/teamviewer8/tv_bin/teamviewerd -f
/opt/teamviewer8/tv_bin/wine/bin/wineserver

and it auto-reopens whenever i try to kill it and i wonder why this happens.

Thanks in advance.

share|improve this question
    
I used the debian installer. Even the "killall" doesn't close "teamviewerd" process. – Goblin Aug 4 '13 at 15:46
up vote 36 down vote accepted

Because that is the nature of teamviewer: it is build to respawn.

/opt/teamviewer8/tv_bin/script/teamviewerd.sysv is probably responsible for it.

To stop teamviewer use:

sudo teamviewer --daemon stop 

It will show ...

initctl stop teamviewerd
teamviewerd stop/waiting

and it is gone ...

rinzwind@discworld:/opt/teamviewer8/tv_bin/script$ ps -ef|grep teamviewer
rinzwind 12712 12428  0 18:11 pts/0    00:00:00 grep --color=auto teamviewer

Commands to manipulate the daemon:

teamviewer --daemon status        show current status of the TeamViewer daemon
teamviewer --daemon start         start TeamViewer daemon
teamviewer --daemon stop          stop  TeamViewer daemon
teamviewer --daemon restart       stop/start TeamViewer daemon
teamviewer --daemon disable       disable TeamViewer daemon - don't start daemon on system startup
teamviewer --daemon enable        enable TeamViewer daemon - start daemon on system startup (default)

Regarding comment:

From teamviewer 9 help:

$teamviewer --help

 TeamViewer                      9.0.32150 

 teamviewer                      start TeamViewer user interface (if not running) 

 teamviewer --help               print this help screen 
 teamviewer --version            print version information 
 teamviewer --info               print version, status, id 
 teamviewer --ziplog             create a zip containing all teamviewer logs (useful when contacting support) 

 teamviewer --passwd [PASSWD]    set a password (useful when installing remote (ssh) 

 teamviewer --daemon status      show current status of the TeamViewer daemon 
 teamviewer --daemon start       start      TeamViewer daemon 
 teamviewer --daemon stop        stop       TeamViewer daemon 
 teamviewer --daemon restart     stop/start TeamViewer daemon 
 teamviewer --daemon disable     disable    TeamViewer daemon - don't start daemon on system startup 
 teamviewer --daemon enable      enable     TeamViewer daemon - start daemon on system startup (default) 

Options are still there in TV9.

share|improve this answer
3  
Yep so if you don't want team viewer auto starting use: teamviewer --daemon disable. Doing this mean that next time execute teamviewer you will get a message that says that you need first start the daemon and will also conveniently provide you with the command to do just that. – kroiz Oct 19 '13 at 18:50
    
This answer doesn't work anymore with the new version (9) of Teamviewer – Frodik Sep 28 '14 at 5:14
    
@Frodik yes it does. – Rinzwind Sep 28 '14 at 5:29
    
@Rinzwind Well, not in my case and other users might have problems as well. The only thing which worked for me was killall -9 teamviewerd – Frodik Sep 28 '14 at 5:55
    
On Ubuntu it does: sudo service teamviewerd.sysv stop – silpol Oct 3 '14 at 7:45

If you install Teamviewer 10 from the .deb file, --daemon stop as recommended above won't work in Ubuntu 14.04 LTS (and others?). Don't know why.

The daemon is an 'upstart' job, so it gets controlled from /etc/init/teamviewerd.conf not /etc/init.d.

Unfortunately, for me, both initctl stop teamviewerd and service teamviewerd stop result in:

initctl: Unknown instance: 

teamviewerd.sysv gets installed in /opt. So, to stop it, you need to do:

$ sudo /opt/teamviewer/tv_bin/script/teamviewerd.sysv stop
share|improve this answer
    
For me @rinzwind aswer worked. I am using 14.04 LTS. – akikara Feb 20 '15 at 8:22
    
I am on a Xubuntu 14.04 and sudo teamviewer --daemon disable, which I found in another question somewhere, worked. Might want to try that. – Zelphir Jan 30 at 15:45

I use Ubuntu 12.04, but I do not think the process will be different using other versions of Ubuntu.

Team Viewer screen sharing is my choice to replace the now "TOO BLURRED TO READ" Skype screen share. The window sizes are about the same on my screen, but I can now read the print whereas the Skype blur makes reading impossible.

Please note that although Team Viewer runs under Wine, there are many native scripts that also run.

There has been some notice of the "TeamViewer remote control daemon" (teamviewerd) remaining active after the user is finished using and terminated teamviewer. Respawning is also used to make sure it stays active. The easiest solution is to reboot or logout after making sure the 'start with system' check box is cleared. When you log in, team viewer should not start and the daemon should not appear.

If you want a solution that does not require logging out, you must delete the respawn commands from the configuration file.

In the terminal, enter:

gksudo gedit -s /etc/init/teamviewerd.conf

Delete the two lines:

respawn

respawn limit 5 60

Save the file. Do not worry about the teamviewerd.conf.bak file.

Now that respawn is disabled, ending the daemon will end it. I did not notice anything unusual in the way teamviewer functions with the modified script.

Note: the changes will not initially take effect until teamviewer reads the script. Reboot, log-out, or terminate and restart teamviewer are options. I only tried log-out and it worked for me. I did not try the other options as I modified the script only once.

share|improve this answer
    
I am now using Ubuntu 14.04 and I just "stop" the teamviewerd process so it will no longer function until I "continue" the teamviewerd process so you can run teamviewer again. You may use gnome-system-monitor as root [gksudo gnome-system-monitor] if your version of the gnome-system-monitor does not offer to authenticate the stop or continue commands. I do not use the terminal commands, so I am unable to share them with you. – James Jadesword Oct 24 '15 at 5:19

I am using Ubuntu 14.04. I have no idea what the 'teamviewerd' process does, but I found that it is required to use TeamViewer. I use the 'gnome-system-monitor' to stop the 'teamviewerd' process when I reboot and when I am finished using TeamViewer. I 'continue' the process before I start using TeamViewer.

The version I am currently using of the 'gnome-system-monitor' will ask for the authorization password when the 'stop' or 'continue' request is made. If your version of the 'gnome-system-monitor' does not ask for the authorization password and denies your request, you will need to start the 'gnome-system-monitor' in the terminal:
   gksudo gnome-system-monitor

If you are not familiar with the usage of the gnome-system-monitor, follow these suggested steps:
   select the 'Processes' tab
   select the 'teamviewerd' process
   right click and select 'Stop Process' or 'Continue Process'

share|improve this answer

Here is the script "teamviewer.bash" I am using and that works in 14.04:

#!/bin/bash
# to be copied to /opt/teamviewer/tv_bin/script
# modify /usr/share/applications/teamviewer-teamviewer11.desktop :
# Exec=bash /opt/teamviewer/tv_bin/script/teamviewer.bash
# sudo visudo
# add:
# user ALL=(ALL:ALL) NOPASSWD:/opt/teamviewer/tv_bin/script/teamviewer
# sudo service sudo restart
echo 'teamviewer --daemon enable' | sudo sh && \
/opt/teamviewer/tv_bin/script/teamviewer && \
echo 'teamviewer --daemon disable' | sudo sh
share|improve this answer

teamviewer is using upstart to fire up the daemon at boot. The upstart does have a respawn set to keep a process running. As a 12.04 user mentioned, respawn stanzas in the upstart script are probably what you want to comment out.

The teamviewer process is/will run as root if fired up upstart. Since the respawn is in the upstart script you could have issues killing it permanently whether you do an implicit kill or 'sudo stop teamviwer' (the upstart way) or 'sudo teamviewer --daemon status'. Your best bet is probably just to comment out respawn lines in the upstart script, then start and stop as the service as needed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.