Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems that when I try to compress a file using gzip (.gz), it copies original file to temp directory, compress the copied file in temp, and then move the compressed file from temp to original directory. This process uses so much system resource and also HDD read/write. How can I tell gzip to compress files in their own directory (just similar to 7zip)

P.S. I checked gzip application in windows ,too. It was the same.

EDIT: to be more clear, I'm using nautilus compress option and I want to set it to compress files in place by default.

share|improve this question
    
What is the command you are using? And also, are you saying that the copies of the original files then remain in /tmp? –  Sparhawk Aug 4 '13 at 6:49
    
sorry, I was unclear. I used GUI (nautilus compress option). I checked when using gzip command it copress in place, but nautilus copies to .cache. it removes all copied files at end. –  mohammadh montazeri Aug 4 '13 at 7:13
    
Sorry, I'm not 100% sure, because I don't use Nautilus. Obviously, another answer would be to use the command line gzip, but I suppose you'd like to know how to change the defaults of Nautilus. So, sorry, not sure. –  Sparhawk Aug 4 '13 at 10:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.