Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual-monitor setup using the proprietary Nvidia drivers. It appears that the correct settings are used when the OS boots (it appears to be fine at the login prompt), but when I login, the settings for my dual montior are reset and the position of the second monitor is incorrect (it should be set to the right of my main monitor).

I removed xorg.conf from the /etc/X11 directory and AFAIK the only one on the system is in /usr/share/X11/xorg.conf.d/12-xorg.conf (I checked /var/log/Xorg.0.log and it says that it is using /usr/share/X11/xorg.conf.d/)

Here are the settings:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.14  (buildd@aatxe)  Tue Oct 16 22:21:09 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen         0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2311H"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS 512"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "MetaModeOrientation" "CRT-1 RightOf DFP-0"
    SubSection     "Display"
    Depth          24
    EndSubSection
EndSection

System info:

  • Xubuntu 12.04
  • Nvidia proprietary driver version 310.14
  • X.Org X Server 1.11.3
share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

The following fixed the issue:

  • I manually upgraded the NVIDIA drivers to 319.32 (may not have been necessary)
  • I modified the xorg config file MetaModeOrientation options to the following:

    Option "MetaModeOrientation" "CRT RightOf DFP"

share|improve this answer
add comment

Run nvidia-settings as root, with:

 gksu nvidia-settings

enter image description here

Set the dual monitor the way you want it (cloned or extended) and save the configuration using the "Save X configuration to file" in /etc/X11/xorg.conf

If you're not sure, make first a backup of such file like this before you edit it:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

In the worst case, you can recover from the backup doing this from a terminal:

sudo cp /etc/X11/xorg.conf_backup /etc/X11/xorg.conf

Good luck!

share|improve this answer
    
Unfortunately this doesn't work. The configuration file that was created should work, and when I look in the Xorg.0.log I can see that it loads it, but it still doesn't set the correct position for the second monitor. The config file I have in the /usr/share/X11/xorg.conf.d/ appears to be correct (I modified the automatically generated one, but followed the instructions in Nvidia's README). [ 7.461] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 4 11:46:38 2013 [ 7.463] (==) Using config file: "/etc/X11/xorg.conf" –  TheAmpersand Aug 4 '13 at 15:48
    
Here's the screen section of the generated file: Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "Stereo" "0" Option "nvidiaXineramaInfoOrder" "DFP-0" Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0; DFP: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0; DFP: nvidia-auto-select +0+0; DFP: nvidia-auto-select +0+0" SubSection "Display" Depth 24 EndSubSection EndSection –  TheAmpersand Aug 4 '13 at 15:50
    
You could try to copy that file, if it's correct, to your home directory: cp /etc/xorg.conf /home/yourusername/.xorg.conf With a dot to make it hidden. –  darent Aug 8 '13 at 21:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.