Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tar 1.22 installed and I need tar 1.20. I tried:

sudo apt-get install tar=1.20

but I got:

Version '1.20' for 'tar' was not found

When I looked more closely it turned out that the current version is not just 1.22, but 1.22-2ubuntu1. So I tried:

sudo apt-get install tar=1.20-2ubuntu1

But still got the that error message.

Any idea how do I install tar 1.20 on my Ubuntu?

share|improve this question

3 Answers 3

Hardy, the long term version from 2008 has 1.19. I know it is not the same as 1.20 but I guess it is the closest you can get using canonicals blessed bits. Try to download the three files from the right side of this page: http://packages.ubuntu.com/hardy/tar and use dpkg-buildpackage to make a package suitable for your distribution. After that, you need to force the installation with dpkg -f -i because you're probably downgrading.

I am left wondering why would you do such a thing. Is 1.22 giving you a hard time?

share|improve this answer

If it is not in the repositories and you can't find any PPA for it then you'll have to build from source.

You can get the source here.

share|improve this answer

You should try sudo apt-get install tar=1.22-2ubuntu1, rather than sudo apt-get install tar=1.20-2ubuntu1, because those are different versions. Note that the latest version may not be included in the repositories for your version of Ubuntu, in which case, get the source from the link given by Octavian here, and you can then build it from source.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.