Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problems using my wifi connection under Ubuntu 13.04. As many others also reported, Thema realtek driver RTL8192CU causes connection problems.

Edit: This happens on two different machines (Ubuntu 13.04 and Ubuntu 12.10; Kernels 3.5, 3.8 & 3.9)

In my case it seems to disconnect every time the kernel tries to reduce the TX power: wlan1: Limiting TX power to 27 (27 - 0) dBm as advertised by ...

Question: is it possible to prevent the kernel/driver from doing this?

dmesg snippet I found many times in the log:

[   69.721477] wlan1: authenticated
[   69.721887] rtl8192cu 2-2:1.0 wlan1: disabling HT/VHT due to WEP/TKIP use
[   69.725351] wlan1: associate with 00:18:84:23:50:4a (try 1/3)
[   69.744272] wlan1: RX AssocResp from 00:18:84:23:50:4a (capab=0x431 status=0 aid=2)
[   69.744348] wlan1: associated
[   69.744606] cfg80211: Calling CRDA for country: NA
[   69.772495] wlan1: Limiting TX power to 27 (27 - 0) dBm as advertised by 00:18:84:23:50:4a
[   76.075829] rtlwifi:rtl_watchdog_wq_callback():<0-0> AP off, try to reconnect now
[   76.075859] wlan1: Connection to AP 00:18:84:23:50:4a lost

nm-tool: (At this time it was connected to my wifi (Becks) and browsing the internet was not possible.)

- Device: wlan1  [Becks] -------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192cu
  State:             connected
  Default:           yes
  HW Address:        EC:1A:59:10:4B:35

  Capabilities:
    Speed:           18 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    EasyBox-FF0700:  Infra, 7C:4F:B5:FF:07:30, Freq 2422 MHz, Rate 54 Mb/s, Strength 94 WPA WPA2
    FRITZ!Box Fon WLAN 7170: Infra, 00:04:0E:89:40:21, Freq 2437 MHz, Rate 54 Mb/s, Strength 94 WPA
    belkin.3948:     Infra, 08:86:3B:E0:80:48, Freq 2412 MHz, Rate 54 Mb/s, Strength 92 WPA WPA2
    Delidovich's Home: Infra, 64:70:02:F6:FD:54, Freq 2452 MHz, Rate 54 Mb/s, Strength 92 WPA2
    *Becks:          Infra, 1C:C6:3C:35:FC:44, Freq 2417 MHz, Rate 54 Mb/s, Strength 76 WPA
    ASUS:            Infra, C8:60:00:94:9A:F6, Freq 2417 MHz, Rate 54 Mb/s, Strength 92 WPA

  IPv4 Settings:
    Address:         192.168.1.2
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1
share|improve this question

3 Answers 3

up vote 0 down vote accepted

When your computer is trying to associate with the AP or access point with the mac address or BSSID 00:18:84:23:50:4a is where your problem begins because your BSSID for Becks is listed as 1C:C6:3C:35:FC:44. Also, 00:18:84:23:50:4a appears to be using WEP and your netowrk uses WPA authentication.

First, use a terminal to navigate to '/etc/NetworkManager/system-connections' with sudo. Gnome and the Ubuntu desktop use nautilus, Kde uses dolphin, and XFCE uses thunar but here I will show nautilus for the purpose of explaining this.

sudo nautilus '/etc/NetworkManager/system-connections'

Check to see if this folder contains any profiles saved for networks you do not use. You must have some configuration for the network your computer was trying to connect to. Deleting any unneeded profile will prevent future attempts to automatically connect to these networks. You should only have profiles here for the networks you want to keep.

Now to the internet. If your computer shows a connection to the router but you can't get a connection to the internet, you may be having some kind of a subsequent issue. The loss of connectivity may have resulted in the loss of an external DHCP lease and you may need to reset your modem.

Some routers use a single external DHCP lease from the modem for the main wired connection to the internet, generating an individual internal DHCP lease for each of your devices to use on the local network automatically. This allows devices to connect without having to obtain a new lease. Other times, each individual device on the network is assigned an external lease depending on the type of router and settings you use.

share|improve this answer

There are several access points nearby with greater signal strength than Becks, to whom you are connected. I suspect Network manager is seeing these access points with better strength and attempting to roam to another. I suggest you right-click the Network Manager icon and select Edit Connections. Edit the wireless connection Becks as here: enter image description here

Mark it to connect automatically and fill in Becks BSSID (MAC address) to tell Network Manager that you wish to connect to only Becks and only the MAC address you specified.

share|improve this answer
    
Thanks. But this did not help. It still claims to be connected to "Becks" but can not send nor receive any data. What helps is sitting right next to the acces point. –  Simon Aug 8 '13 at 20:49

I'm not familiar with this specific problem, but I'd start with the tool powertop (requires root permissions). It has a "Tunables" section (Right arrow scrolls through sections) where you can turn on/off various power saving related features.

share|improve this answer
    
Thank you! Power management for the adapter has already been already off, according to powertops. So this did not solve my problem. –  Simon Aug 3 '13 at 9:50
    
Please see here: permalink.gmane.org/gmane.linux.kernel.wireless.general/110364 Do you have several competing access points nearby? Please edit your question to add: nm-tool –  chili555 Aug 3 '13 at 13:49
    
@chili555: What do you mean with "..add: nm-tool"? As a tag? This is not available. I have only one access point and the error also occurs in an completely different environment (other house) with an other access point. –  Simon Aug 5 '13 at 11:13
    
@Simon: Sorry if I was unclear. I meant to run the terminal command nm-tool and post the result so we can examine the number and strength of nearby access points that may be competing. Network Manager will try to roam to another access point if it even momentarily appears stronger. At this point, I think you have a Network Manager issue, not an rtl8192cu issue. I also think the "limiting TX power..." message is unrelated. –  chili555 Aug 5 '13 at 12:45
    
thx @chili555 ! Now I added the output. –  Simon Aug 6 '13 at 17:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.