Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using windows Vista 32 bit, and I want to install Ubuntu 12.04 by using vmware player. But after I install it, the Ubuntu desktop looks like this :

Graphic Error

Can someone help me please, is this a compatibility issue? Thank you.

EDIT :

I tried using VirtualBox, but the I can not enter the desktop at all, I got stuck in tty, and if I pressed F7, this screen came out :

Virtual Box Error

share|improve this question
    
It looks like the simulated hardware that VMware player generates for the VM doesn't play well with Ubuntu's GUI. Try playing with the settings of the VM (maybe enable Settings->Hardware->Display-Accelerate) or some of the options in Settings->Options->Unity. If nothing works, try also Virtualbox, it is also free of cost (and additionally open source) and might work better for you. –  Marios Zindilis Aug 3 '13 at 9:14
    
@MariosZindilis Hello, I tried virtualbox, and I described another error in my comment for Alex reply. –  dulipat Aug 3 '13 at 12:02

2 Answers 2

It's probably Unity or some other dependency of it. Unity is the graphical user interface for Ubuntu, and it's clearly pointing to the wrong... Everything.

You should still be able to jump to another tty screen (another terminal interface) by using

Ctrl + Alt + F6

You can use any of F1-F6, they all have separate terminal states respectively. Remember this utility when the GUI fails.

From the terminal, login with your username and password, then type

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop

Breakdown of commands with quick references. If you don't know what the code is you're entering, you should always find out first, as a principal. This promotes learning, and system stability.

"sudo" - admin command, if you run this before anything it will grant you root privileges when running the command (requires root password)

"apt-get" - this is a package manager application, use it to manage software and git repositories. Very multifunctional.

"apt-get update" - updates the repositories and gets a list of any and all new software to be downloaded.

"apt-get install --reinstall" - full command broken down, apt-get (application), install (command to application, tells it to install a package), and --reinstall (optional command tagged to the install command. Reinstalls the specified package)

"ubuntu-desktop" - contains many different software packages related to the Ubuntu desktop, and GUI.

EDIT

I see that comment now. I never had a problem with virtual box, you should try it if this doesn't work.

share|improve this answer
    
I tried you suggestions on VMWare Player, it didn't work, Then I tried to use VirtualBox, but I can not enter the desktop at all, stuck in the tty screen. And when I tried to press ctrl+alt+F7, this screen came : [link] (i1160.photobucket.com/albums/q498/dulipat/error_zpsa90ab910.jpg) Any other suggestions? Thank you. –  dulipat Aug 3 '13 at 11:15
    
I'm at work right now, and a bit hung over, but I'll get back to you tonight after midnight sometime (-8pst) –  Alex Aug 5 '13 at 1:18

Having the same problem, using Ubuntu 12.04 with VMPlayer 6.0 on a Windows 7 host. Unity doesn't seem to display correctly at all.

I have installed Xfce and it's ok then. Didn't try with Gnome 3.x, but I think it should work. So :

sudo apt-get install xfce4 xfce4-goodies

And then, disconnect and chose Xfce.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.