Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just compiled the 2.6.39-rc1 kernel and AppArmor complains about a missing /sys interface (plus, it slows down the boot). Where do I get the AppArmor 2.4 compatibility patch AppArmor asks for?

share|improve this question
up vote 4 down vote accepted

There are two ways:

  1. You can find the patches for various kernel versions in the kernel-patches directory in the sources of the package apparmor:

     apt-get source apparmor
    
  2. You can grab the patches directly from the web (replace precise with whatever version you are running).

share|improve this answer
1  
The kernel.org link is still down as of now. Ubuntu hosts the patches at bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/apparmor/… – Lekensteyn Dec 23 '11 at 23:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.