Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I accidentally formatted my hard disk containing ubuntu partition. I also run a windows vista. I formatted my 2nd hdd, the ubuntu partition. after I reboot I'm getting a message

error:no such device:2fe5264c-df46-4507-9eee-8a7f1335c846
grub rescue>"

I also tried to boot from my liveCD by changing the bios menu.

I tried the following settings in the bios

  • 1st boot - cdrom \ usb
  • 2nd boot - hdd \ cdrom \disabled
  • 3rd boot - usb \ hdd \disabled Still the same error is repeated. I also tried the following commands

    grub rescue> ls (hd0) (hd0,msdos1) (hd1) (hd1,msdos1) (fd0) grub rescue> ls (hd0)/boot in all possible combinations

I get the error error: unknown filesystem

Except for the command ls (fd0)\boot I get error : fd0 read error. I totally formatted my 2nd hdd. My system is Desktop, P4, hdd1 80GiB (vista), hdd2 30GiB (ubuntu)(formatted) , 1GiB DDR RAM. now I cannot even load my Windows OS.

I also tried to install windows 8 using USB and liveCD, but it didn't work. I can't even read my cd or usb drives.

Please someone help me.

share|improve this question
    
I'm sorry to say, that it looks like your HDD is corrupt. You can obviously get to the Grub rescue prompt. When there, can you run the command sudo fdisk -l /dev/fda and let us know what the results are. –  SimplySimon Aug 2 '13 at 19:37

1 Answer 1

In case we had not written to the accidentally formatted drive we are able to fully recover partitions with

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.