Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Manufacturer: Sierra Wireless, Incorporated Product: AirCard 340U

Serial No.: XXX

uname -a

Linux XXX 3.5.0-36-generic #57~precise1-Ubuntu SMP Thu Jun 20 18:21:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.2 LTS
Release:        12.04
Codename:       precise

lsusb

Bus 002 Device 007: ID 1199:9051 Sierra Wireless, Inc.

I have tried: sudo modprobe usbserial vendor=0x1199 product=0x9051

[  191.236770] USB Serial deregistering driver Sierra USB modem
[  191.236809] usbcore: deregistering interface driver sierra
[  191.237679] USB Serial deregistering driver generic
[  191.237705] usbcore: deregistering interface driver usbserial_generic
[  191.237721] usbcore: deregistering interface driver usbserial
[  202.268461] usbcore: registered new interface driver usbserial
[  202.268482] usbcore: registered new interface driver usbserial_generic

No wwan or ttyUSB devices show up.

sudo apt-get install usb-modeswitch

usb_modeswitch -v 0x1199 -p 0x9051 -S 1 -W
Trying to send Sierra control message
USB error: error sending control message: Broken pipe
Error: sending Sierra control message failed (error -32). Aborting.

So far no way to start connectivity.

I also tried: [url]http://www.freedesktop.org/wiki/Software/ModemManager/SupportedDevices/[/url] sudo apt-get install modemmanager

which won't work since these are headless servers.

Any help would be appreciated.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.