Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know a lot of posts have been written, and I had read most of them when I encountered the problem. None of them solved the problem.

I have successfully installed Ubuntu 12.04 on top of Windows 8. Now my PC simply boots into Windows 8.

If I press 'Esc' at start of BIOS, and then F9,the GRUB shows up and Ubuntu is listed at the top of the several options to boot from.

I did run Boot-Repair once I logged into Ubuntu explicitly from GRUB as mentioned above. I did all said by Stormvirux in this link but was still unsuccessful.

The debug info is listed here.

Something which confuses me is the message which Boot-Repair stated after it did its job.

You can now reboot your computer. Please do not forget to make your BIOS boot on sda (8004MB) disk! The boot files of [The OS now in use - Ubuntu 12.04.2 LTS] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (https://help.ubuntu.com/community/BootPartition)

I don't know why it says it is far from the start of the disk as I see it first in the GRUB menu which comes up at startup.

One more input, when I try to place the GRUB in sda, Boot-Repair does not progress giving me the following error:

GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag).   
This can be performed via tools such as Gparted. Then try again.
Alternatively, you can retry after activating the [Separate /boot/efi partition:] option.

I had to select Separate /boot/efi partition: sdb2

share|improve this question

2 Answers 2

According to your description, you have correctly installed the GRUB bootloader in UEFI mode. You do not need any BIOS-boot partition, nor any other partition change.

The only remaining issue is to set up your BIOS (UEFI firmware) so that it boots by default the GRUB entry instead of the Windows entry. In other words, we need to find a way so that you won't need to press 'Esc' then F9 to reach the GRUB menu.

To perform this, please:

  1. check the 'Boot order' menu in your BIOS, and try to place the "Ubuntu" entry first. Then save the change and reboot. If GRUB still does not appear by default, please follow step 2 below.
  2. run Boot-Repair --> Advanced Options --> tick the Backup and rename the Windows EFI files option --> Apply. Tell us the new URL that will appear, reboot, and tell us what you observe. The PC should now boot directly onto the GRUB menu.
share|improve this answer
    
Thanks a lot guys for looking into this. First of all i tried Option 2) by LovinBuntu and voila it solved my problem. Now the grub shows up. Actually i previously did the same renaming but it did not work then. May be because the usb stick(with Ubuntu os boot image) was attached to PC while performing all the operations. ONE MORE HELP. The grub shows up a lot of options(with Ubuntu, Windows included). How do i just get it to display Ubuntu and Windows? –  user180630 Aug 2 '13 at 16:46
    
Boot-Repair adds a lot of efi options into 25_custom. You can backup that file and edit out any you do not want. And since grub2's os-prober is not working you can also turn it off. If you need details on how post back. –  oldfred Aug 2 '13 at 18:14
    
Open a terminal and type gksudo gedit /etc/grub.d/25_custom , then remove the unwanted entries, save the file, then type this 2nd command: sudo update-grub. Alternatively, you can use GRUB-Customizer. –  LovinBuntu Aug 2 '13 at 19:58

You have UEFI and have grub installed to efi partition. Your system did promote the flash drive to sda and made your 1TB drive sdb, but it still should boot ok.

You must be booting Boot-Repair in BIOS mode if a grub reinstall is asking for a bios_grub partition. That is only required to correctly install grub to the protective MBR that gpt partitioned drives have to boot in BIOS mode. But you really want to boot in UEFI mode.

I have not seen boot issue on any UEFI based system with grub or kernel files far into hard drive. But some BIOS based systems would not boot if kernel or grub were beyond 100GB on drive. Those needed a separate /boot nearer start of drive.

From UEFI menu, can you boot Ubuntu with secure boot on or with it off? It shows you have also installed signed kernel so it should even boot with secure boot on.

If you then still have issues after grub menu, then it may be something else like video issue. What video card/chip do you have?

share|improve this answer
1  
Fred, I think there is no video issue. He is correctly booting both Windows and Ubuntu in UEFI mode (the log shows B-R used from the installed UEFI session, line621). The only issue he has is that the default boot is not on GRUB/shim UEFI but on Windows UEFI entry. That may be a case of firmware blocked onto /EFI/Microsoft/... efi file. –  LovinBuntu Aug 2 '13 at 15:38
    
I think that LovinBuntu is correct here; see the efibootmgr output in lines 1114-1148. The computer seems to be set to boot ubuntu (GRUB), but is in fact booting Windows by default. This may indicate a buggy EFI, which may require setting the "Backup and Rename Windows EFI Files" option in the Advanced menu of Boot Repair. –  Rod Smith Aug 2 '13 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.