Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed Springseed here (http://www.omgubuntu.co.uk/2013/07/springseed-note-taking-app-for-ubuntu) : Note taking app on Ubuntu 12.04 lts i386, just wont work. it pretty much installed correctly, downloaded the .deb from the website here (http://getspringseed.com/) and installed it via software center. The thing just won't start ? On clicking the icon post- installation, blah, NO GUI, nothing shows up et all !? Is it with me only ? Uninstalled the app, downloaded again and ran it, No success. Care to comment ? ! Thanks.

share|improve this question
2  
Try running /opt/springseed/springseed-bin in Terminal, what is the output? Are you installing springseed_1.0.1~fix1.deb and for the correct architecture (32 bits, 64 bits)? –  Micheal Harker Aug 1 '13 at 20:06

2 Answers 2

up vote 4 down vote accepted

To start the program, you can just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

/opt/springseed/springseed-bin

Or you can create a shortcut on the desktop to start the application from. Just do gksu gedit springseed.desktop, when it opens copy and paste the below info into the file, and then save it on the desktop as springseed.destop

[Desktop Entry]
Version=1.0
Name=SpringSeed
Comment=
Exec=/opt/springseed/springseed-bin
Path=/opt/springseed/
Icon=/usr/share/icons/<pick-an-icon>
Terminal=false
Type=Application
Categories=Utility;

Note: You may have to do gksu nautilus to edit the properties.

enter image description here

enter image description here

note you might need to install gksu with:

sudo apt-get install gksu
share|improve this answer
    
Guess that helped. Thanks. Wonder why the shortcut won't work ?! :O –  ASCIIbetical Aug 2 '13 at 13:03
    
Are you talking about the newly created shortcut? If you are I've added images to show what the properties are. If this answered your question, you may mark this answer as accepted. –  Mitch Aug 2 '13 at 13:25
    
Well thanks for the pictorial as well. Though i ran the command : chmod +x *.desktop it pretty much made that executable. Thanks for the help. Though, nah mate, i am not talking abt that icon. Your answer is working and great. and so is,@Micheal Harker also. Iam talking about why the default icon that's inside unity under applciations hood, wonder why that doesn't work ? Though will mark your answer as accepted. Thanks. –  ASCIIbetical Aug 2 '13 at 13:39
    
I really don't know why no icon shows under Dash. You may want to file a bug with SpringSeed. If you feel that the answer is not up to par for you, that's OK :) –  Mitch Aug 2 '13 at 14:04
    
Mitch, i got that. Its basically path error under /usr/share/applications "Springseed". Now it works fine. though your answer is great as well, but then i thought, if i can get the original icon work. So, Thanks ! :) –  ASCIIbetical Aug 2 '13 at 14:11

I solved the whole query and made the icon under the Unity _ Application's hood to respond again. Its actually simple.

Open a terminal (Ctrl+Alt+T) and then write gksu nautilus, It will ask for your password. File manager Nautilus will open, (be careful here).

Go to /usr/share/applications directory and find "SpringSeed". Right click on it, and go to properties, under command section this will be written:

LD_LIBRARY_PATH=/opt/springseed /opt/springseed/springseed-bin

Select all that text and delete it, and write:

LD_LIBRARY_PATH=/opt/springseed/springseed-bin

That's all. Works fine for me. And guess will work for everyone else as well. ! :)

Thanks Mitch and Micheal Harker. Now close Nautilus, exit that terminal, go to Unity, search for Springseed, woila, it will run. ! :)

share|improve this answer
1  
"You should never use normal sudo to start graphical applications as Root", so you should run gksu nautilus and not sudo nautilus. Furthermore, Ubuntu developers definitely "prefer us not to use GUI applications as root", so gksu is not even installed by default in 13.04. So, if you really need to run nautilus or other GUI application with root privileges, you can install from repositories or use pkexec. –  carnendil Aug 27 '13 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.