Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble with viewing RAW files of the type CR2 taken with my Canon EOS 6D camera.

The images show up in normal colors first, then after ~1 second gets a pink overlay added. This happens in all software, Shotwell, Gimp, Darktable etc.

The problem has happened after I did a clean reinstall of Xubuntu. I did not have this problem before reinstalling.

Anyone got an idea?

Example

enter image description here

share|improve this question
    
All of these programs rely on libraw for processing RAW files. Have you tried reinstalling that package? –  MrEricSir Aug 2 '13 at 0:00
    
I had this problem in 12.04. I no longer have it after upgrading to 13.04. –  user183461 Aug 12 '13 at 12:08
add comment

1 Answer

This is due to LibRaw, the library Shotwell relies upon for RAW processing. LibRaw is based on dcraw.

We've seen this problem pop up on various cameras over the years. The problem is usually solved in dcraw at some point, at which point the code migrates to LibRaw, where it's eventually available to Shotwell. It may be that dcraw / LibRaw still doesn't process your camera's images correctly; it just depends when the authors fix these problems.

What to do? First, I recommend upgrading to the newest version of Shotwell and LibRaw if possible. I don't know what version of Xubuntu you're using, so I don't know if that requires upgrading your operating system. You can find the latest version of Shotwell at Yorba's PPA: https://launchpad.net/~yorba/+archive/ppa Even if your version of Xubuntu has an old copy, you may be able to upgrade to the latest (0.14.1) through our PPA.

Second, if that doesn't work or you can't upgrade easily, you should try changing the RAW Developer to Camera in Shotwell. This is available by selecting the photo and choosing Photos -> Developer -> Camera. If you see this problem with all your RAW photos, I suggest changing the default RAW Developer to Camera in Edit -> Preferences.

The Camera Developer uses the RAW file's built-in JPEG file (or paired RAW+JPEG if that's the case). This JPEG is created by the camera itself and shouldn't have discoloration issues. You can probably try the second step right now and see if you get the right results; either way, I recommend upgrading if at all possible.

NOTE: I didn't notice until I posted the above that you're using the Shotwell Photo Viewer (i.e. you're double-clicking on the RAW file in Nautilus). The Camera Developer is only available in Shotwell's library mode, that is, you run Shotwell and import the photos into your library.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.