Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created a live USB of windows 7 with unetbootin. I'm running Ubuntu 12.04. I have a Lenovo z580 intel core i7 with 8gb ram. My computer won't boot from USB. USB is first in the boot order. My stick is flagged as boot in gparted. I tried booting from usb via system setup from the grub menu. It just sends me back to grub. BTW the usb stick is formatted fat32 (as per a recommendation that unetbootin will fail with NTFS) however I also tried with it formatted to NTFS and it also fails to boot from USB.

share|improve this question
add comment

1 Answer

I think your USB MBR (Master Boot Record) has corrupted. Open Terminal and type these commands:

sudo apt-get install mbr
fdisk -l (to find out which device is your flash drive)
install-mbr /dev/sdx (replacing x with your flash device)

and then create the live USB again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.