Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 13.04 on a desktop I built myself, and I've been having an issue for a few weeks now.

I installed an update for my system a while ago, and when I restarted, it would log me in, and then nothing would happen. It still shows that I connect to my wireless network, which shows me that the system itself is still working, but the only thing on my screen is my mouse cursor, which is still responsive. I can also press ctrl+alt+T for terminal and log out using ctrl+alt+del.

I've tried searching online for a fix, because I have an inkling that it has something to do with the desktop environment thing, but obviously I don't know the proper terminology, and that's made it pretty hard to find a solution! If someone could point me in the right direction, and hopefully tell me what the "environment" is called, it would be much appreciated!

I've tried the suggestions here , but the first one didn't work for me, and whenever I try to open TTY1/TTY2, my system doesn't work... It just shows a screen with all sorts of different colors, and it looks like it just bricked itself or something.

Thanks again!

share|improve this question
    
What is the model number of the graphics card in your computer if you have one? –  karel Aug 1 '13 at 0:55
    
Hi, I have an AMD 7850. –  ImBakinBacon Aug 1 '13 at 0:55

1 Answer 1

Your black screen, problem getting to your desktop environment and mosaic screen artifacts could all be caused by a graphics card driver issue. From the terminal type:

sudo apt-get install fglrx fglrx-amdcccle

...and reboot the system.

fglrx is the video driver for the AMD Radeon and FireGL graphics accelerators.

share|improve this answer
    
I just tried this, and now when I boot up, I get a "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" error. I've had troubles with the open source drivers in the past, so I had to install the drivers via downloading the packages from AMD's websites before. EDIT: Looks like it has nothing to do with the driver? Do I have to completely reinstall the OS now? It won't let me boot into safemode anymore either. –  ImBakinBacon Aug 1 '13 at 1:12
    
Okay, so update on this again. Now when I boot up, the black screen occurs right after the GRUB Bootloader, so I can't access the terminal at all when booting normally. I can boot into safemode now, however. –  ImBakinBacon Aug 1 '13 at 1:30
    
It's good that you can at least boot into safe mode. Your "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" might be caused by a hardware issue of the desktop you built yourself. I recommend that you ask about this in a separate question because the threads that I have read on this topic get bogged down in a lot of hardware specific details. For this reason I also recommend that you add information about your CPU, RAM, hard drive and graphics card to your question. –  karel Aug 1 '13 at 1:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.