Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a wi-fi home network. My friends windows computer is able to play youtube videos with his windows machine in the same network. And I am able to play youtube videos using my iPhone's 3g network using my ubuntu machine. So, it seems my browser works fine.

$ cat /etc/resolve.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

I enabled html5 using youtube.com/html5

I restarted nscd,

$ sudo /etc/init.d/nscd restart

I restarted the computer and the modem several times, however the problem still remains. In the home-wifi-network, I am not able to play the youtube video.

Youtube webpage opens, everything is fine, however the video does not play. ping youtube.com works fine.

Ubuntu version: Ubuntu 13.04,

Browsers: Firefox, chromium, google-chrome

share|improve this question
add comment

1 Answer 1

1: The file (actually a symbolic link) /etc/resolve.conf should be named /etc/resolv.conf. Make sure it is a symbolic link to ../run/resolvconf/resolv.conf.

2: Disable the NetworkManager-controlled local forwarding nameserver. Edit NetworkManager.conf

sudo gedit /etc/NetworkManager/NetworkManager.conf

and comment out the line dns=dnsmasq

#dns=dnsmasq

and then restart NetworkManager.

sudo restart network-manager

Ref: https://bugs.launchpad.net/ubuntu/+source/dnsmasq/+bug/1003842

share|improve this answer
    
I am somehow unable to reproduce the bug right now.. And I don't remember what has fixed the problem.. –  celebisait Aug 12 '13 at 18:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.