Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 12.04, and I'm having some issues in connecting to my home's wifi. Here's the quick resume:

  1. my home wifi works, because I'm surfing trhough ethernet
  2. my wireless drivers work, because I can successfully connect to my office's wifi
  3. I'm not even able to ping my router!

So, I cannot understand the reason for it to not work! I'm using ubuntu 12.04. Here are informations about the connection and similar:

alecive@calliope:~$ nm-tool 

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unavailable
  Default:           no
  HW Address:        00:24:BE:EB:DA:87

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0  [InfostradaWiFi-004309] ---------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        00:27:10:2B:68:28

  Capabilities:
    Speed:           135 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    FASTWEB-1-00219631C110: Infra, 00:21:96:31:C1:18, Freq 2462 MHz, Rate 54 Mb/s, Strength 82 WPA
    Vodafone-23070663: Infra, 00:24:89:94:F6:AE, Freq 2437 MHz, Rate 54 Mb/s, Strength 50 WPA2
    belkin.0bc:      Infra, 08:86:3B:57:20:BC, Freq 2412 MHz, Rate 54 Mb/s, Strength 44 WPA WPA2
    Ivica:           Infra, 00:11:50:36:9C:EB, Freq 2412 MHz, Rate 54 Mb/s, Strength 27 WPA
    Paola WiFi:      Infra, F8:D1:11:62:8C:CF, Freq 2462 MHz, Rate 54 Mb/s, Strength 20 WPA WPA2
    FASTWEB-1-0021964482E4: Infra, 00:21:96:44:82:EC, Freq 2462 MHz, Rate 54 Mb/s, Strength 20 WPA
    ciao wireless:   Infra, 00:25:9C:88:68:56, Freq 2462 MHz, Rate 54 Mb/s, Strength 27 WEP
    TISCALI:         Infra, 00:24:17:D9:2A:B7, Freq 2462 MHz, Rate 54 Mb/s, Strength 27
    *InfostradaWiFi-004309: Infra, AC:E2:15:4A:35:74, Freq 2427 MHz, Rate 54 Mb/s, Strength 90 WPA
    LEPRE35:         Infra, 58:98:35:7E:D6:9B, Freq 2412 MHz, Rate 54 Mb/s, Strength 24 WPA WPA2
    TP-LINK:         Infra, 00:14:78:EC:40:AA, Freq 2437 MHz, Rate 54 Mb/s, Strength 24 WPA WPA2
    Alice-92034414:  Infra, 00:19:3E:15:82:B0, Freq 2437 MHz, Rate 54 Mb/s, Strength 22 WPA
    MAMADOU:         Infra, F0:7D:68:11:3F:E7, Freq 2437 MHz, Rate 11 Mb/s, Strength 24 WPA WPA2
    M&A:             Infra, 00:17:F2:E4:83:67, Freq 2412 MHz, Rate 54 Mb/s, Strength 29 WEP
    Vodafone-26148616: Infra, 00:24:89:82:19:EE, Freq 2412 MHz, Rate 54 Mb/s, Strength 22 WPA2
    FASTWEB-1-001CA2AE2E70: Infra, 00:1C:A2:AE:2E:70, Freq 2437 MHz, Rate 54 Mb/s, Strength 20 WPA

  IPv4 Settings:
    Address:         192.168.1.8
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             8.8.8.8
    DNS:             8.8.4.4


alecive@calliope:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:24:be:eb:da:87 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:27:10:2b:68:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.8/24 brd 192.168.1.255 scope global wlan0
    inet6 fe80::227:10ff:fe2b:6828/64 scope link 
       valid_lft forever preferred_lft forever
alecive@calliope:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
^C
--- 192.168.1.1 ping statistics ---
13 packets transmitted, 0 received, 100% packet loss, time 12094ms

alecive@calliope:~$

Can someone please help me? Thanks!

share|improve this question
add comment

1 Answer

A few things to check or remember 1. Check if another wireless device will connect and surf. Ethernet is wired and a router can work fine using the Ethernet while the wireless section is kaput. 2. Check your Firewall as that may blocking access to wireless connections. It appears that your computer is working correctly, you are just blocked. You can also try 'dhclient wlan0' which should reset your IP and may fix the issue.

share|improve this answer
    
1. Yes, a number of devices (a win8 machine, three android smartphones, even an ubuntu machine can surf through wireless) 2. How can I check the firewall? Through the router page? 3. I'll try dhclient wlan0 and I'll tell you if it works! :) –  alecive Aug 1 '13 at 19:52
    
Ok I just checked. I typed "sudo dhclient wlan0" and nothing changed. By the way, also nothing has been printed on the terminal! –  alecive Aug 3 '13 at 7:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.