Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to make a bootable Ubuntu 12.04 LTS on my KINGSTON Flash drive. But somehow it always fail to boot.

I obtain the *.iso from http://www.ubuntu.com/download/desktop, and I use unetbootin on my windows 7 to create the bootable flash. After reboot and choose to boot from USB Flash Drive, I got the following message:

Boot Error
_  <-"I can type stuff here"

I try another method and create the bootable using universal USB Installer, this time after I reboot and choose to boot from the USB Flash Drive this following message show up:

SYSLINUX 4.06 EDD 2012-10-23 copyright 1994-2012 Peter Anvin et al
ERROR: No configuration file found
No default or UI configuration directive found!
Boot: "I can type stuff here"

I tried to rename the isolinux folder, isolinux.cfg and isolinux.bin into syslinux folder, syslinux.cfg and syslinux.bin. But the same thing as above still occur.

I haven't tried ubuntu at all (or any other linux in that matter). I decided to try ubuntu after recently my windows 7 blue screen on me quite frequently. But I can't make any decision before I try the ubuntu at least once. Therefore I am grateful for any help.

share|improve this question
    
Did you ever used your same flash drive to install Windows? (like making it bootable using Windows 7 USB/DVD Tool and install Windows from it.) –  Kush Jul 31 '13 at 8:31
    
I haven't. I bought the drive especially to install Ubuntu last night. –  junda Jul 31 '13 at 10:10
    
See if instructions given in my answer helps or not. –  Kush Jul 31 '13 at 10:12
    
Will do, Thank you very much. –  junda Jul 31 '13 at 10:22
add comment

1 Answer

I've faced this issue several times when I've used my flash drive to install Windows and then make it bootable to install Ubuntu. In this case, all that your flash drive needs is marking it as Active. Follow instructions as below.

Go to Windows and Open command prompt as Administrator.

Now, run diskpart command which will open within command prompt.

View list of drives connected.

list disk

You should see output something like below.

Disk ###  Status         Size     Free     Dyn  Gpt
--------  -------------  -------  -------  ---  ---
Disk 0    Online          465 GB      0 B
Disk 1    Online         3820 MB      0 B

Where Disk 1 is your Flash Drive (notice it by size). Now select that disk. BE CAREFUL THAT YOU SELECT YOUR FLASH DRIVE.

select disk 1

Now list partitions that the drive has.

list partition

Output should be something like as follows (showing only single partition ideally):

Partition ###  Type              Size     Offset
-------------  ----------------  -------  -------
Partition 1    Primary           3819 MB    64 KB

Select that partition.

select partition 1

Now mark it as active.

active

You're done! run exit and close command prompt.

Now you can create it bootable again, from Ubuntu ISO and try if it boots to Live Desktop. I'd suggest you to use Universal USB Installer to do that.

Hope that helps.

share|improve this answer
    
Thanks, I'll try this immediately and will report here afterwards. –  junda Jul 31 '13 at 10:12
    
I follow your instructions but unfortunately it still didn't work. But in frustration I borrow 4 USBs from my friend and make bootable on all 4 of them and voila, one of them work wonderfully. Probably my drive is the one at fault. I also try to make windows 7 installatoin in it and it also fail epically. –  junda Aug 1 '13 at 4:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.