Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am tri-booting Mac OS 10.6.8 (Snow Leopard), Windows 8, and Ubuntu. I installed via a USB drive. The install and the LiveCD trial went flawlessly, and I can boot into GRUB. However, as soon as I press Enter on the installed Ubuntu, it brings me to a black screen. I left it there for about an hour, and it was still black. No words or anything. I tried 13.04, and that worked, but it wasn't 100% compatible, so I much prefer the LTS. So far, I have tried:

  • Failsafe Graphics
  • Reinstalling
  • Putting nomodeset and no splash in GRUB
  • The custom Mac LiveCD (wouldn't boot from the USB drive)
  • Adjusting my brightness (believe it or not, that's a common solution)
  • Switching graphics mode through GRUB (got a garbled mess, but I think Unity was running in there somewhere because my backlit keyboard lit up)
  • Entering --quiet splash nomodeset and quiet splash nomodeset (brought me to the splash screen with orange dots, then kicked me back out to a totally black screen)
  • Pressing Esc during the splash screen (gave me a bunch of checks, all came back [OK], but kicked me to the black screen again)

Keep in mind, I'm kind of a beginner. I know much more than the average beginner, but I wouldn't call myself intermediate just yet.

One more thing: the black screen I'm getting is NOT backlit, and there is NO blinking cursor. It looks as if I turned the computer off, but the fans are still running and I think the hard drive is still doing something)

share|improve this question
    
Have you tried booting Ubuntu from the built in boot manager? As your computer is starting up, hold/tap the OPTION key, then select Ubuntu. –  Jeremy Aug 14 '13 at 3:46
    
Yeah, sadly it's not there. I can really only get to it through rEFIt –  Jart Aug 15 '13 at 17:39
add comment

2 Answers

Have you tried to add nomodeset after --quiet splash I have a MacBook Pro 5,2, and this is what I must do.

Boot up and wait for grub, press C, use arrow keys and add the option.

share|improve this answer
    
I tried doing both --quiet splash nomodeset and quiet splash nomodeset They both brought me to the splash screen with the logo and orange dots, but it kicked me to a black screen after that –  Jart Jul 31 '13 at 6:14
add comment

Have You tried pressing the ESC Button when the Splash Screen appears? You should see a couple of messages scrolling down.

Check if you can get a Login Shell this way. :)

Also, you can Boot into Run Level one by Editing the GRUB Entry that you are using to boot Linux, and Append 1 to the end of the Line starting with the linux Word

share|improve this answer
    
Pressed Esc at the splash screen. A bunch of text started scrolling (they were almost all checks and they all said "OK"). Sadly, it kicked me out to the black screen. Also, I could not find a line in GRUB that started with the "linux" Word –  Jart Jul 31 '13 at 6:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.