Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To make a long story short, (trying to install lightscribe), It has installed to computer>opt>lightscribe>simple labeler> (launchbrowser.sh), which is a root folder. I am trying to open a terminal and cd to the folder so I can take ownership so I can run the program. However every time I try the cd command I get the error msg "user/HOME/computer does not exist". How do i do this, or is there a better way of accessing this program, I really don't want to have to reboot into windows every day just to burn a few disk. I have seen several forum post where other people were having problems and eventually got it working, and I tried what they did and it did not work for me.

share|improve this question
1  
how did you install lightscribe - was it through the Software Center, or something else? If you followed some online instructions, please post a link to them. –  ImaginaryRobots Jul 30 '13 at 23:03
2  
Are you sure that's the correct path? It seems more likely that the path would be /opt/lightscribe/simple\ labeler. –  konapun Jul 30 '13 at 23:17
    
To install, I downloaded the two files, double-clicked the file, which opened the software center. As far as the links to the instructions I followed there were 10-12 different things I tried, a few were from this site, the rest from other Ubuntu/linux sites. The location (I double checked) is opt/LightscribeApplications/SimpleLabeler/launchbrowser –  Acer DeVille Jul 30 '13 at 23:22
    
What is the output of ls -al /opt/lightscribe/simple\ labeler/ ? –  Amanda Jul 30 '13 at 23:38
    
@AcerDeVille the leading / is not trivial in a file path. /opt/ligthscribe is not (necessarily) the same directory as opt/lightscribe –  Amanda Jul 30 '13 at 23:39

2 Answers 2

Firstly, I'm not sure what you mean by "user/HOME/computer does not exist". I figure out what you're calling "computer" is the root directory, which under Linux is denoted with a slash character / at the beginning of the pathname. Hence in order to cd there, all you have to type is:

cd /opt/lightscribe

And notice how the pathname begins with a /. Also, if you're going to cd to a folder whose name contains a space, you will need to escape it, either using a backslash before the space, as in...

cd /opt/lightscribe/simple\ labeler

... or by quoting the whole pathname:

cd "/opt/lightscribe/simple labeler"

Now secondly, I don't really think you need to take the ownership of a program in order to run it. Almost all programs we install are installed somewhere under the root folder, owned by the root user -- not in normal users' home directories, and not owned by them.

Whether the program's main binary is under somewhere like /usr/bin or inside /opt doesn't make a difference. You can read and execute files be them here or there (And if this weren't the case, you wouldn't be able to even browse the directory in your GUI file manager). The only thing you can't do is modifying them, which is a good safety measure that you should not bypass unless you absolutely have to.

That all being said, since you can browse there, then the problem is just mistyping the path in the terminal. The tips above should suffice to typing it correctly, I think. And keep in mind that pathnames under Linux are case-sensitive. You can't type HOME or Home if the folder is called home.

Finally, and to make life easier, I think any file manager you might be using should have an "Open terminal here" command so that you don't have to separately open a terminal and manually cd all the way to where you are. Usually it's found in the context menu popped up by right-clicking over an empty area (and not a file or directory).

Hope this helps. (Edit: I'm slowpoke, people already answered.)

share|improve this answer
    
quote/ Firstly, I'm not sure what you mean by "user/HOME/computer does not exist"\quote The terminal automatically starts in the home folder, however to get to the opt file, you open the file manager, and on the far left hand side, you come down to computer. When trying to cd to the computer folder, the terminal tries to find the file "computer" inside the home folder. All the files for the program to run are there, however it does not show up in the software center, so I don't know if its installed or not, I just want to get a icon on my desktop so I can run the program. –  Acer DeVille Jul 31 '13 at 0:41
    
GREAT NEWS! I don't know what I did but it started working. Thanks for all the help. –  Acer DeVille Jul 31 '13 at 11:45

Error messages are usually trying to tell you something. If the folder exists but you don't have permission to view/execute it, the error will say so. So your first problem is to figure out what directory you should be launching from.

Then, if you have permission to run the script running it from the command line should work fine:

% /opt/lightscribe/simple\ labeler/launchbrowser.sh

Or, it will give you a new, different, equally useful error to work from.

share|improve this answer
    
Also, make sure the file is executable by chmodding it with chmod a+x launchbrowser.sh –  konapun Jul 30 '13 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.