Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I bought a new printer, a Canon Pixma iP7250 which connects via wi-fi. I installed it using the supplied Canon drivers for Linux and I can print wirelessly without problem from every program in Ubuntu except Libre Office. When I try to print a document (either existing or new, either a .odt or a .doc) the printer icon shows for about 10 seconds and then disappears. Going into ‘view print queue’ and looking at the document I just tried to print, it says ‘job completed’, but when I press the refresh button it momentarily says ‘printer not found’. If I save the document as a pdf, it prints fine from pdf viewer, but this can only be a temporary workaround. I also have the same version of Libre Office on an old Windoze machine running XP and I can print from that without any problem, so this must be an Ubuntu issue. I am running 13.04.

I have looked both in the printer settings and the printer settings within Libre Office and cannot see anything untoward. In have also searched the internet via Duck Duck Go and even, in desperation, used Messrs Page & Brin’s search engine, but I could not find anything on this particular issue.

I would be very grateful for any advice on this issue, as I tend to print more from Libre Office than any other program.

Thanks

share|improve this question
    
Would you kindly report on your current version of LibreOffice? –  carnendil Jul 30 '13 at 18:25
    
Hi, yes, it's 4.0.2.2 –  Chris Burmajster Jul 30 '13 at 18:44
    
Check the paper size in both page size in Format --> Page, and paper size in File --> Printer Settings. –  Mitch Jul 30 '13 at 18:46
    
Both are set to A4. –  Chris Burmajster Jul 31 '13 at 9:12
    
LO appears not to see the printer at all. –  Chris Burmajster Jul 31 '13 at 11:42

1 Answer 1

After having said that everything else prints except LO, I discovered that I could not print a photograph today and the problem was the same - 'printer not connected'. I solved it by deleting the printer, connecting it via USB and re-installing it as a local printer. Now it prints from LO, photos, Firefox etc. Wi fi connection just doesn't work on Ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.