Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I have updates, Ubuntu 12.04 demands a partial upgrade - but the partial upgrade insists on removing QGIS and GRASS, two GIS packages that I use. I don't want to loose these packages (which both work fine). How do I force Ubuntu to leave them alone, without jeopardizing my security? I also do NOT want to "upgrade" to anything newer than 12.04. The last upgrade I had to make (10.04LTS to 12.04LTS) required a few days work to eliminate the "Unity" and get things working under an acceptable (working) Gnome desktop - much of the (private) specialized software I use didn't like Unity. (I will NEVER use Unity, which I despise!)

(Edit: this has been going on for maybe 2-3 months now, and is very irritating - and Update Manager now will not update the kernel without first doing a "partial upgrade".)

share|improve this question
    
dont go for partial upgrade. wait for a week or so and then reupdate the cache again. –  AgentCool Jul 30 '13 at 17:12

1 Answer 1

I had a similar issue. I was able to resolve it by manually installing the packages:

sudo apt-get install gdal-bin grass-core grass-gui libgdal-dev libopenscenegraph80 
libosgearth1

You can find the packages using:

sudo apt-get upgrade

Otherwise you can also try:

sudo dpkg --configure -a

There are some more answers that might help you here.

share|improve this answer
    
The problem is still there, and now I've got a computer with an older kernel (than the latest update). It won't update the Kernel or many other packages. I've tried everything suggested here and in a couple of other places without success. The update manager is insisting that QGIS and GRASS are "No Longer Needed" and insists that they must be deleted. I use both of them regularly. –  user179848 Aug 8 '13 at 18:19
    
BTW... when I tried to install grass-gui by apt-get, the response was that grass-gui didn't exist. I looked it up and added the repository suggested, but still - no grass-gui. –  user179848 Aug 8 '13 at 18:22
    
That's peculiar. I was able to update my kernel using the method described above. I did encounter the same issue with the last update but was able to update the other packages by unselecting the qgis and grass packages that give problems and update them later via the terminal. Don't know why it doesn't work on your computer. Maybe the last thing you can try is to de-install qgis and grass, update the kernel and re-install after that? –  BlankUsername Aug 8 '13 at 19:35
1  
FIXED. I ended up deleting the repository for GIS files, then re-installing it. That seemed to eliminate one of the files that the update manager wanted to eliminate and it could find the main grass software (but still wouldn't update properly). I tried "installing" GRASS by itself using the terminal. That fixed that problem, and update manager showed three less files needed for "partial upgrade". Then updating again using the terminal reduced the partial upgrade to a few support files which had newer versions. Then I ran the partial upgrade and everything was OK. Nothing lost. –  user179848 Aug 10 '13 at 16:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.