Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 on my X201e (it came without any OS).

First I had a problem with wired connection not recognized. I ran

sudo apt-get update
sudo apt-get upgrade

and Ethernet is working now.

However the problem lies with the wireless. The scenario is always the same: it works for about 30sec-1min after booting up, showing ping latency to the router around 1ms. Then suddenly the latency rises to about 700ms-800ms, internet no longer works and in the end the connection to the router is dropped. Then it resumes, or I press FN+F2 to close and resume the connection, it works for about 30sec and back to high latency and finally dropping.

I followed the advice found at Launchpad created the file, set boot priority, to no avail.

I also did this How can I get wireless to stop disconnecting on my ASUS X201E? but updating to 12.10 resulted in black screen upon boot and I had to reinstall the system.

Also tried to follow this How to resolve wireless disconnect problem in Atheros ath9k but the files are unavailable for download, only from version 3.7.

I am no Ubuntu guru as you may guess, really like the OS, but for such a fundamental feature as WiFi, I'm afraid I'll have to go back to ms :(

thanks in advance for any ideas/suggestions

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.