Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed 4GB RAM on my Thinkpad X60 running Ubuntu 12.04. Then I've installed PAE-enabled kernel. Now uname -r outputs

3.2.0-50-generic-pae

My CPU is capable of PAE:

$ grep pae /proc/cpuinfo
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts aperfmperf pni monitor vmx est tm2 xtpr pdcm dtherm
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts aperfmperf pni monitor vmx est tm2 xtpr pdcm dtherm

BIOS reports 4096MB RAM.

Yet free outputs

             total       used       free     shared    buffers     cached
Mem:       3088452    2264192     824260          0     168056     852880
-/+ buffers/cache:    1243256    1845196
Swap:      2085884          0    2085884

What's wrong?

Edit: Here's the e820 dmesg section:

[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[    0.000000]  BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000d2000 - 00000000000d4000 (reserved)
[    0.000000]  BIOS-e820: 00000000000dc000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 00000000bf6d0000 (usable)
[    0.000000]  BIOS-e820: 00000000bf6d0000 - 00000000bf6df000 (ACPI data)
[    0.000000]  BIOS-e820: 00000000bf6df000 - 00000000bf700000 (ACPI NVS)
[    0.000000]  BIOS-e820: 00000000bf700000 - 00000000c0000000 (reserved)
[    0.000000]  BIOS-e820: 00000000f0000000 - 00000000f4000000 (reserved)
[    0.000000]  BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[    0.000000]  BIOS-e820: 00000000fed00000 - 00000000fed00400 (reserved)
[    0.000000]  BIOS-e820: 00000000fed14000 - 00000000fed1a000 (reserved)
[    0.000000]  BIOS-e820: 00000000fed1c000 - 00000000fed90000 (reserved)
[    0.000000]  BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
[    0.000000]  BIOS-e820: 00000000ff800000 - 0000000100000000 (reserved)
share|improve this question
    
Do you have a built in display adapter? If yes check in the BIOS and see how much RAM its using. –  Mitch Jul 30 '13 at 8:29
    
I don't know what's a built in display adapter. I have a notebook, so I have a built-in display. But I had 2GB before and most of it was available, so why would some adapter take 1GB all of a sudden? –  janek37 Jul 30 '13 at 8:51
    
Your machine has the Intel GMA 950, which uses shred RAm, so it might have used more after the upgrade. See your BIOS for display adapter setting, or something similar. –  Mitch Jul 30 '13 at 9:03
    
In my BIOS config section I have a menu of Network, Serial portm Infrared, Modem, Parallel port, PCI, USB, Keyboard/Mouse, Display, Power, Alarm, Memory, SATA, CPU. Under Display there's only Bood Display Device, HV expansion, Brightness. Under memory there's only Extended Memory Test. I've found askubuntu.com/questions/167042/…. Maybe my motherboard suffers from similar issue. –  janek37 Jul 30 '13 at 9:51
    
It a possibility. See if there is a BIOS update for you machine. See this post on how to update under Ubuntu. –  Mitch Jul 30 '13 at 10:01

1 Answer 1

up vote 0 down vote accepted

Turns out it's probably a motherboard/BIOS issue and there's no workaround. Similar to 64-bit and 32-bit 12.04 report 1GB less ram.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.