Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an issue with Windows Recovery Environment after the Ubuntu installation, in particular after the installation of GRUB2. On sda1 I've got a Windows 7 installation thing (bootable, something like previously supplied Windows installation CD but on HDD, the biggest mistake of Microsoft). On sda2 I've installed Windows 7 which now I need to reinstall.

GRUB2 sits at the first 512 b of sda with the following 4 entries:
• Linux ...
• Linux recovery ....
• Windows 7 ....
• Windows 7 recovery env...

Everything works OK except for the Windows Recovery Environment. The entry for Windows Recovery Env is as follows:

insmod part_msdos
insmod ntfs
set root='(hd0, msdos1)'
search --no-floppy --fs-uuid --set da1e-3be0
drivemap -s (hd0) ${root}
chainloader +1

After choosing Windows 7 recovery env, I get the following error:

booting a command list
error: no argument specified,
Press any key to continue...

...and then a black screen with a blinking cursor appears.

I think I've tried everything that I could only think of. I remember that when I first installed GRUB2 I had to do some manual changes to Windows 7 entry because it wouldn't run either. So I tried in a various ways to modify the entry for Windows recovery, but with no luck. I even did a backup of MBR (first 512 b of my sda) and tried to restore the Windows boot from some other Windows installation CD by running bootrec /fixmbr and then /fixboot... but after this the thing got even worse because then on PC startup instead of loading Windows directly, I only got a black screen with an annoying blinking cursor, so I had to recover my Grub2 from the backup to boot anything at all.

Is there any way to get to the sda1 and boot the Windows Recovery thing from it? I would be very grateful for any kind of hint!

share|improve this question

1 Answer 1

If the data of the recovery software has been damaged, you may have to resort to a new copy of win7 in place of it. The second repair attempt probably caused a few conflicts if they were different versions. It has happened to me before. The corrupt recovery software was the initial issue, if the initial install had overlay software at the beginning of the drive, it may have not have moved it all when grub was installed. This would cause a corruption of the boot segment of the recovery partition. The manufacturer does not make it easy to repair/modify the recovery software for fear of piracy. It is in effect the same thing as a broken cd or corrupt iso. It has to be replaced w manufacturer's disc or be replaced with a install that doesn't have a recovery partition in use. Grub is having trouble with the location of the start of the recovery. see https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/663137 for referance to a sample grub cfg config. I think what you are looking for is 40% down page... Hope this helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.