Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a MacBook Pro (7,1) where I installed Ubuntu successfully. I have now changed hard drive, and restored MacOSX successfully.

I then went about restoring the ubuntu partition, and copied it across from the old disk with dd. Unfortunately, rEFIt doesn't recognise it as an ubuntu partition any more, and if I boot into it anyway it says "Missing operating system".

What can I do to restore my old ubuntu partition from the old hard drive to the new one? Am I missing any steps?

share|improve this question
    
Have you tried booting from the boot manager? Hold/tap the OPTION key when restarting –  Jeremy Aug 14 '13 at 3:56
    
Yes, I get the same error message "Missing operating system" –  gozzilli Aug 17 '13 at 10:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.