Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.10 with XFCE 4.10. Firefox version 20.0.

Whenever I try to download any files (eg, right-click and download, anything like that), there's a significant delay (~15 seconds). It doesn't matter how large the file is -- a 20kB file has a delay, and so does a 10MB file. I've tried clearing out the list of previously-downloaded files, but that didn't help.

I also have Chromium installed, but it doesn't have the same delay problem.

Any suggestions?

Currently mounted drives/devices

/dev/sda7 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda5 on /boot type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/home/xxxxxx/.Private on /home/xxxxxx type ecryptfs
    (ecryptfs_check_dev_ruid,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,
    ecryptfs_unlink_sigs,ecryptfs_sig=xxxxxxxxxxxxxxxx,ecryptfs_fnek_sig=xxxxxxxxxxxxxxxx)
gvfsd-fuse on /run/user/xxxxxx/gvfs type fuse.gvfsd-fuse 
    (rw,nosuid,nodev,user=xxxxxx)
/dev/sda3 on /media/xxxxxx/8C4896FB4896E36E type fuseblk 
    (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1 on /media/xxxxxx/DATAPART1 type fuseblk 
    (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

This is a dual-boot Windows 7/Ubuntu 12.10 machine, and /dev/sda3 and /dev/sdb1 are the Windows volumes C: and D: respectively.

share|improve this question
1  
Do you see the delay when you run Firefox in safe mode? Press Alt+H+R to restart Firefox with add-ons disabled. –  user25656 Jul 29 '13 at 15:19
    
Do you happen to have any remote filesystems mounted? I noticed a similar delay elsewhere, that turned out to be caused by my NAS waking up. –  Jos Jul 29 '13 at 15:21
    
The same delay happens in safe mode. I sometimes have some Novell drives mounted, but they're not mounted now, and I'm still seeing the delay. I'll add the results of mount to my question, in case they're salient. –  Pat J Jul 29 '13 at 15:56
    
You may be better off asking this question here as it appears to be a Firefox issue. However, I would be curious to see what happens if you start Firefox with a blank profile: firefox -ProfileManager –  Jos Jul 29 '13 at 16:45
    
@Jos -- It's a Firefox issue, yes, but it's only happening for me on Ubuntu 12.10/XFCE. My Windows machine at home works fine, but both my work machine and my laptop (both Ubuntu 12.10 with XFCE) exhibit the delay. Also, Firefox with a brand-new blank profile still exhibits the delay. I'll contact Mozilla, too, thanks. –  Pat J Jul 29 '13 at 18:23

1 Answer 1

up vote 0 down vote accepted

Apparently it was not necessarily a Firefox issue. I updated some other packages and the problem went away after the reboot. I can't say for sure what the issue was, but it's solved now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.