Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

today I wanted to install the nvidia driver (from the nvidia site), but something went wrong. First I blacklistet the nouveau driver by adding this line

echo "blacklist nouveau" | sudo tee -a /etc/modprobe.d/blacklist.conf to /etc/modprobe.d/blacklist.conf

(of course I've done a backup)

After that I went to terminal by pressing alt+F1 and stopped the lightdm by this command sudo stop lightdm.

Next I launched the installation and it went through OK

However, after restarting my unity doesn't start.

  • I have already tried startx, but it doesn't help.
  • I decided to restore my blacklist.conf and delete the generated conf file.
  • Later I removed the nvidia driver and the right display resolution was restored but unity still doesn´t work.

PS: I already restored the blacklist.conf and it has 55 lines, but at startup I get the message:

libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/blacklist.conf line 57: ignoring bad line starting with ´echo

Any ideas? Thanks in advance

EDIT:

root@Aspire-5750G:~# lspci -nnk | grep -iA2 vga 00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) Subsystem: Acer Incorporated [ALI] Device [1025:0504]

Kernel driver in use: i915

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1) Subsystem: Acer Incorporated [ALI] Device [1025:0505] Kernel driver in use: nouveau root@Aspire-5750G:~# /usr/lib/nux/unity_support_test -p OpenGL vendor string: Intel Open Source Technology Center OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile OpenGL version string: 3.0 Mesa 9.1.3

Not software rendered: yes Not blacklisted: yes GLX fbconfig: yes GLX texture from pixmap: yes GL npot or rect textures: yes GL vertex program: yes GL fragment program: yes GL vertex buffer object: yes GL framebuffer object: yes GL version is 1.4+: yes

Unity 3D supported: yes root@Aspire-5750G:~# dpkg -l | grep -i nvidiaroot@Aspire-5750G:~#

share|improve this question
    
What is your graphic card's model ? Maybe the driver you downloaded and attempted to install, does not support your card. And why you want to install a driver from Nvidia's site ? Why you don't use the already existed proprietary (Ubuntu checked) drivers ? –  NikTh Jul 29 '13 at 12:48
    
Thanks for your reply. I´ve got a GT 540M. I didn´t know there are so many problems. My Ubuntu Version is 13.04. –  Gera Jul 29 '13 at 13:25
    
We will need some commands output to be sure that you un-installed the driver correctly. Edit your question and add the results. lspci -nnk | grep -iA2 vga /usr/lib/nux/unity_support_test -p dpkg -l | grep -i nvidia –  NikTh Jul 29 '13 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.