Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a problem.

I've installed Raring Ringtail, and have done all the updates.

However, my hardware, Geforce 310M, is not detected and does not appear in additional drivers (software update).

I have tried to install the driver manually, I got the source from here, thanks for that. But my Ubuntu gave some errors, so I re-installed again.

Can somebody help me? Sorry for my bad English, also I'm absolutely newbie Ubuntu user.

result of lspci | grep VGA :

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 310M] (rev a2)
share|improve this question
    
Can you please edit your question and include result of lspci | grep VGA. –  Web-E Jul 29 '13 at 11:21
    
probably duplicate of this solution for hybrid-graphics-cards posted here : askubuntu.com/questions/311151/… –  dschinn1001 Jul 29 '13 at 16:34
add comment

1 Answer

up vote 0 down vote accepted

Have you tried writing this on terminal?

sudo apt-add-repository ppa:xorg-edgers/ppa

sudo apt-get update

sudo apt-get install nvidia-current nvidia-settings

These commands apply on ubuntu versions 13.04, 12.10 & 12.04! Hope it covers you.

share|improve this answer
    
After 2nd command, it give result : <br> 'code' W: GPG error: packages.medibuntu.org raring Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783 –  elhvdz Jul 29 '13 at 16:35
    
@elhvdz Try this fix : sudo apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 2EBC26B60C5A2783 Then type again the above commands in terminal that I gave you to install the drivers. The ppa I gave you is not outdated, so I assume it will work after this fix. Tell me if it is all ok now. –  George Kourouleas Jul 29 '13 at 16:44
    
W: GPG error: packages.medibuntu.org raring Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783 –  elhvdz Jul 29 '13 at 17:02
    
So the fix that I proposed failed after trying that? That should have worked, to be honest. The error still persists? sudo apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 2EBC26B60C5A2783 sudo apt-get update –  George Kourouleas Jul 29 '13 at 17:14
    
Try this link as well, if mine does not work out. –  George Kourouleas Jul 29 '13 at 17:54
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.