Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am a new in ubuntu. So, the problem is, that i have installed nvidia-current drivers on Ubuntu 13.04 on my macbook pro(geforce 320m videocard), and after that, when i am trying to boot, there is a black screen. But the difficulty is, that tty is not working, so i can't remove this drivers. What should i do? Thank you in advance

share|improve this question
    
Hi, and welcome to Ubuntu. Have you tried to start the computer in recovery mode from the GRUB menu? –  SimplySimon Jul 29 '13 at 9:19
    
But in that question all answers about commands in terminal, but i cant open tty –  ratkke Jul 29 '13 at 9:24
    
You possibly can start in recovery mode, as SimplySimon suggests. –  Danatela Jul 29 '13 at 9:31
    
@Danatela What should i choose in recovery mode? Run in failsafe mode - again black screen with not working tty. Also i repaired broken packages(i don't know why) and updated grub bootloader. Nothing changed. –  ratkke Jul 29 '13 at 9:52
1  
askubuntu.com/questions/162075/… –  Danatela Jul 29 '13 at 9:55

1 Answer 1

This link shows you how to boot into recovery mode. Use root with networking enabled.

https://wiki.ubuntu.com/RecoveryMode

Run this code to remount your hard drive with read-write privileges.

mount -o remount,rw /

Then remove your nvidia drivers. Someone has already made a great guide on that, here on the site.

How can I uninstall a nvidia driver completely ?

It should work for Ubuntu 13.04 as well, I use the same thing.

By the way, Nvidia drivers are just a pain. If you can survive with the neuveau drivers, use them. Otherwise, I suggest you get your computer fully updated from the PPAs, do a full shut down and boot, install the Nvidia drivers again, (or try another driver) and do another full reboot. If it works great, if not try again all over from your black screen problem. This I found is the best way to get it working, and I did get my GTX570 HD working beautifully, and I can even update the driver every time a new version comes out and they usually all work, no matter what driver I install now.

share|improve this answer
    
On this hard i also have os x, does mount -o remount,rw / can be dangerous for it? –  ratkke Jul 29 '13 at 10:01
    
I don't believe so. It only mounts the root filesystem for Ubuntu with read-write privileges. I've never used OSX, but I use that code all the time and it's never messed up my dual boot of Windows. –  Alex Jul 29 '13 at 10:05
    
Nothing changed. After i typed your command, i restarted my computer, tried to download ubuntu, and again black screen without tty(and because of that i cant delete nvidia drivers) –  ratkke Jul 29 '13 at 10:25
    
It's probably best to just reinstall Ubuntu and try again. Next time you install Nvidia drivers, update your pc completely, do a full reboot, and try installing the drivers, and nothing else, and reboot once more. That's how I got mine to work. –  Alex Jul 29 '13 at 10:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.