Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a new solid state hard drive (Samsung SSD 840 Pro) and am trying to install Windows 7 and Ubuntu 13.04. I'm coming across the known issue of Ubuntu not recognizing the Windows partition, and Windows not being able to work with the Ubuntu filesystem.

Here are some things that I've tried and the associated problems:

  • Installing Windows 7 first, and then trying to install Ubuntu. I have exactly the same issue as this person (ie, nautilus sees Windows and I can mount, but gparted thinks the entire drive is unallocated). Unfortunately the accepted solution basically only says "use gdisk" - if anyone could give step-by-step directions it would be much appreciated.

  • Installing Ubuntu first, making sure to generate an NTFS partition for Windows (and of course a swap and boot partition). In this case Windows does see all of the partitions, but claims that it can't install on the NTFS partition. I don't remember the error off the top of my head (and I currently have Win7 installed, so no way to check) but it was along the lines of the filesystem being wrong. The error was only one sentence and seemed fairly generic.

Let me know if any terminal output would be helpful. Here's the output of fdisk -l:

ubuntu@ubuntu:/$ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x28554056

Device Boot      Start         End      Blocks   Id  System
   /dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
   /dev/sda2          206848   250066943   124930048    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 8100 MB, 8100249600 bytes
256 heads, 51 sectors/track, 1211 cylinders, total 15820800 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot      Start         End      Blocks   Id  System
   /dev/sdb1   *       12144    15820799     7904328    c  W95 FAT32 (LBA)

Any advice is appreciated!

share|improve this question
    
Try sudo fdisk -l –  Mitch Jul 29 '13 at 9:23
    
Updated, thanks. –  alexvas Jul 29 '13 at 9:25
add comment

1 Answer

up vote 0 down vote accepted

Windows only installs to gpt partitioned drives with UEFI, but you are not showing an efi partition. Windows in BIOS mode will automatically convert a gpt partitioned drive back to MBR(msdos), but does not delete the backup gpt partition table. Then Linux sees MBR and gpt and gets confused. You need to remove backup gpt data on drive so it is only MBR.

FixParts is the easiest way to remove the stray GPT data. GPT fdisk (gdisk or sgdisk) can do it, but the procedure's a bit more involved.

http://www.rodsbooks.com/fixparts/

If system is UEFI and you really want that you have to convert Windows 7 installer to flash and make it UEFI capable. Then install Windows first.

share|improve this answer
    
I have tried formatting and re-installing everything several times, trying both Windows-first and Ubuntu-first. Why doesn't formatting "remove stray GPT data"? Also, do you know why this problem isn't more common? Why might it be that my Windows in particular decided to install without EFI? –  alexvas Jul 29 '13 at 18:15
    
Thank you! FixParts solved the issue in just one command! For future reference, just loading up FixParts as in oldfred's link generated an error message that GPT signatures were detected on my disk. After I chose to delete them and rebooted, Ubuntu could see the Windows partitions. –  alexvas Jul 30 '13 at 2:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.