Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I upgraded Ubuntu to 13.04, last Friday, FX on Unity is very slow.

This is a pretty annoying issue, because everything has an FX: Launcher menu, Appl. Switcher and so on.

I tried to disable something using Compiz, and now I can work, but I didn't solve everything, I still have the problem.

My hardware configuration is:

Memory:    3.1 GiB
Processor: Intel® Pentium(R) 4 CPU 3.00GHz × 2 
Graphics:  VESA: Intel(r)915G/915GV/910GL Graphics
OS Type:   32-bit
Disk:      115.9 GB
Unity:     7.0.0

Do you think it's possible there's a hardware misconfiguration?

The unity_support_test script reports me this:

/usr/lib/nux/unity_support_test -p

OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)
OpenGL version string:  2.1 Mesa 9.1.3

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

I tried to install 3rd part drivers, but there are no available drivers.

Someone has an idea?

share|improve this question
1  
Welcome to Ask Ubuntu! Please edit your question and add information about what is your Unity version. Also, try installing proprietary drivers. –  Danatela Jul 29 '13 at 8:12
    
Hi Danatela, thank's a lot for your reply, unfortunatelly there are no other drivers for my board :( –  Davide Jul 29 '13 at 8:37
    
Check this answer. It might be in xorg-edgers repository. –  Danatela Jul 29 '13 at 8:41

1 Answer 1

I have the exact same problem. Did you manage to fix it eventually?

12.10 worked perfectly, but 13.04 uses different driver (Gallium 0.4). Also to avoid black screen, I need to boot with "nomodeset" or "i915.modeset=0", and I read that Mesa 2.1 and up has problem with that. It needs KMS.

EDIT: Solved it. Turns out it's trivial issue. Yes, the nomodeset thing messes with graphics driver causing 3D acceleration not to work. The only reason I was using nomodeset was to fix the black screen. Turns out completely unnecessarily. I boot normally, get 'black screen' ...and fix that by hitting Fn+F5 (aka. brightness up button). :) Now 13.04 is running fast with 3D acceleration.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.