Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I downloaded dwarf fortress linux edition, fired up terminal, decompressed the bz2 (still in the downloads folder), cd ~/Downloads/df_linux, then:

~/Downloads/df_linux$ ./df
./df: 6: ./df: ./libs/Dwarf_Fortress: not found
~/Downloads/df_linux$ cd libs
~/Downloads/df_linux/libs$ ls -al
total 21408
-rwx------ 1 ***** ***** 15104448 Jul  29  14:06 Dwarf_Fortress
-rw-r--r-- 1 ***** *****   466491 Jul  29  14:06 libgcc_s.so.1
-rwxr-xr-x 1 ***** *****  1451966 Jul  29  14:06 libgraphics.so
-rwxr-xr-x 1 ***** *****  4852343 Jul  29  14:06 libstdc++.so.6
~/Downloads/df_linux/libs$

Not found??? It is RIGHT THERE!!! I even tried to copy the Dwarf_Fortress executable into ~/bin, then run Dwarf_fortress on the command line:

~/Downloads/df_linux/libs$ cd ~/bin
~/bin$ ls -la
total 14788
-rwxr--r--  1 ***** *****      243 Jul  29  14:06 df
-rwx------  1 ***** ***** 15104448 Jun  29  14:06 Dwarf_Fortress
~/bin$ df
/home/*****/bin/df: 6: /home/*****/bin/df: ./libs/Dwarf_Fortress: not found
~/bin$ Dwarf_Fortress
bash: /home/*****/bin/Dwarf_Fortress: No such file or directory
~/bin$

Again, the same problem. something is wrong with this

Anyways, if you have been wondering, I ran touch * on the files, and didn't include all stuff in my ~/bin, and export PS1='/w$ ' in my .bashrc

How I Tried to Fix It

Since it tells me that it can't find the exeutable, I edited the last line form ./libs/Dwarf_Fortress to the full path, same error. Then, I tried removing everything but the export command and the execute command (which I changed to the full path to my executable) and same error.

Some reply(s) told me to post the md5sum, it is 33e26a93e5914f7545fa1aaa53706eeb

share|improve this question

2 Answers 2

From the folder with a freshly unpacked dwarf fortress could you run the commands:

pwd; sh -x df

this will allow further debugging of the script that launches dwarf fortress

could you also run:

md5sum Dwarf_Fortress

from the libs folder and paste the checksum as a comment here if thats possible

share|improve this answer
    
pwd? did you see the ls -la commands and the path on the left? sh -x returns exactly the same error –  AbstruselyArcane Jul 30 '13 at 3:41

I believe this is because you're trying to run a 32-bit binary on a 64-bit system. I just downloaded DF 40.13 and it's definitely 32-bit:

~/Downloads/df_linux/libs$ file *
Dwarf_Fortress: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.8, stripped
libgcc_s.so.1:  ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped
libgraphics.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped
libstdc++.so.6: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped

My system is 64-bit:

~/Downloads/df_linux/libs$ uname -a
Linux daedalus 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3 x86_64 GNU/Linux

Here is the result:

~/Downloads/df_linux$ ./df
./df: 6: ./df: ./libs/Dwarf_Fortress: not found

I found a solution here: http://dwarffortresswiki.org/index.php/DF2014:Installation#How-to_for_Debian_and_similar You'll need to issue the dpkg and apt-get commands, then fix up the audio as described.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.