Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I run ubuntu 12.04 on my laptop as a small webserver. For many months, everything went prefectly, but when I moved it to an other house with an other internet connection, it started to boot slowly, showing the message "Waiting for network configuration". I know I edited the /etc/network/interfaces, but I can't recall what I have modified. Obviously, I can't get any internet connection.

Here is the /etc/network/interfaces as it is right now:

# This file...
# and how to...

# The loopback...
auto lo p2p1
iface lo inet loopback

# The primary...
auto p2p1
iface p2p1 inet dhcp

When I type ifconfig -a | grep p2p1 I get

p2p1        Link encap:Ethernet   HWaddr e8:40:f2:df:1c:a6

When I type lshw -class network I get

*-network DISABLED
description: Ethernet interface
(somme other stuff)
serial e8:40:f2:df:1c:a6

Edit: typing ifconfig gives only info about the local loopback and nothing about eth0.

Edit 2: Result of ping -c 3

PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=52 time=28.3ms
64 bytes from ( icmp_req=2 ttl=52 time=26.7ms
64 bytes from ( icmp_req=3 ttl=52 time=28.2ms

--- ping statistics ---
3 packets transmitted, 3 recieved, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 26.713/27.743/28.302/0.754 ms

Therefore, I can decuce that there is an internet connection, which is good news. Starting the computer still gives the same error message.

Edit 3: When shutting down, I get this error message (it might be related):

apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName

Edit 4: On startup, I also get

Starting configure network device               [fail]
Starting configure virtual network devices      [fail]

Typing ifconfig p2p1 gives

p2p1        Link encap:Ethernet HWaddr e8:40:f2:df:1c:a6
            inet addr: Bcast: Mask:
            inet6 addr: fe80::ea40:f2ff:fedf:1ca6/64 Scope:Link
            RX packets:37 errors:0 dropped:0 everruns:0 frame:0
            TX packets:17 errors:0 dropped:0 everruns:0 carrier:0
            collisions:0 txqueuelen:1000
            RX bytes:7839 (7.8 KB) TX bytes:1623 (1.6 KB)

...but ifconfig alone will only give info about the local loopback

Any advise to solve this problem?


share|improve this question
Can you post the output of ifconfig? – linuxk Jul 29 '13 at 3:59
Yes, it gives only information about the local loopback, nothing about eth0. – Adrien Lessard Jul 29 '13 at 4:13
Have you ever seen eth0 in your ifconfig? – linuxk Jul 29 '13 at 4:19
No, I havent't. – Adrien Lessard Jul 29 '13 at 4:27
Okay. Try this. sudo dhclient p2p1 and post the output of ping -c 3 – linuxk Jul 29 '13 at 4:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.